No sound from front audio jack

Yo ho there.

So, the problem is basically as the title says. I’ve got EndeavourOS installed on an ASUS ExpertCenter, and while i can get sound out of the port on the back panel, no sound comes through the front panel.

inxi -Fxxxza --no-host:

Audio:
  Device-1: Intel vendor: ASUSTeK driver: snd_hda_intel v: kernel
    bus-ID: 00:1f.3 chip-ID: 8086:f0c8 class-ID: 0403
  Sound Server-1: ALSA v: k5.19.1-arch2-1 running: yes
  Sound Server-2: PulseAudio v: 16.1 running: no
  Sound Server-3: PipeWire v: 0.3.56 running: yes

dmesg | grep snd_hda gives no output, so no issues there I guess.

What else can I check?

alsamixer could help or pavucontrol
usually, output will detect plugged jack and it should enable the plugged jack output…
alsamixer in terminal and press F6 to choose the card:
2022-08-18_18-25
if you use left right arrow keys to choose one slider you can mute/unmute by pressing M key …

2022-08-18_18-32

And welcome to the purple space! :purple_square:

1 Like

Is it physically connected internally?

The problem seems to be that the sound device defaults to pipewire device. How do i set the default to the actual sound card, or can i uninstall pipewire all together?

pipewire is not a device… it is the default Soundsystem that manages audio devices on the software level…
It is connected with devices and other software like also or apps using pulseaudio…

But i would first try to check what exactly is the reason of the muted front audio…
I know that p.e. on a lot systems what you would call “front output” is called “headphone”

And what Jonathon mentioned to get enabled a hardware jack must be plugged with a connector to be enabled hardware sided… in case you have multiple output connectors plugged it have to default to one and the other will in most case muted… also it is plugged in…
So if you have something plugged in to “back audio output jack” the “front audio jack” is not active … if you plug in a plug into both only one will be unmuted…

you can set all other output devices to “off” with pacvucontrol GUI:
2022-08-19_10-21

This is what opens when I run alsamixer on startup
Screenshot from 2022-08-19 11-13-56
And when it’s like that, I only get sound from the port on the back panel.
I only get all the other controls when I press F6 to switch the card:
Screenshot from 2022-08-19 11-19-44
Screenshot from 2022-08-19 11-20-16

And then I receive sound out of the front jack, and even bluetooth where before I wasn’t getting any sound at all.

I’m not sure what you mean by multiple output connectors, but if you’re referring to the sound card, then I only have the one device. The PC itself isn’t a custom build, it’s an off-the-shelf PC, so yes, the front and back jacks are connected internally. This is what my pavucontrol looks like:
Screenshot from 2022-08-19 11-28-32

can be multiple cards or also headphone Front and Line out from the same card what are 3 output connectors …

alsa mixer is only to check it is not to be used to setup devices and state of connectors… you could use alsa as it is an underlying mechanism to set up audio… but in normal circumstances, it does not need to do that.

but that pavucontrol only shows Build-in Audio could link to an issue … not sure why … it does that and do not show a “real” device name…

it is listed as detected here:

also not a good sign…

your pavucontrol shows this build-in audio as Off is this the state or did you put it off on testing?
2022-08-19_12-17

I would like to see the detailed hardware info from:
inxi -Aa
and
pactl list | eos-sendlog

inxi -Aa produces:

Audio:
  Device-1: Intel vendor: ASUSTeK driver: snd_hda_intel v: kernel
    bus-ID: 00:1f.3 chip-ID: 8086:f0c8 class-ID: 0403
  Sound Server-1: ALSA v: k5.19.1-arch2-1 running: yes
  Sound Server-2: PulseAudio v: 16.1 running: no
  Sound Server-3: PipeWire v: 0.3.56 running: yes

pactl list | eos-sendlog produces

  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
curl: (60) SSL certificate problem: certificate has expired
More details here: https://curl.se/docs/sslcerts.html

curl failed to verify the legitimacy of the server and therefore could not
establish a secure connection to it. To learn more about this situation and
how to fix it, please visit the web page mentioned above.

I didn’t change anything pavucontrol, didn’t even use pavucontrol until your made mention of it :sweat_smile:

Also the output device in pavucontrol and in cinnamon sound settings shows up as ‘Dummy output’. Is that normal?

it should show a device with manufacturer and info… dummy device is mostly a non detected device…

Do you try already reset audio settings ?

remove the configs in users home:
rm -R ~/.config/pulse ~/.local/state/wireplumber
and reboot let them recreate

server error… you can also write the output to a textfile:
pactl list > ~/pactl-list.txt

Tried and the device still shows up as dummy output.
Couldn’t upload the txt file from pactl list > ~/pactl-list.txt so i use 0x0.st instead. Here it is: output

does show that it is not fully detecting your audio device somehow… it does show alsa info:

alsa card info part
Card #42
	Name: alsa_card.pci-0000_00_1f.3
	Driver: alsa
	Owner Module: n/a
	Properties:
		api.acp.auto-port = "false"
		api.acp.auto-profile = "false"
		api.alsa.card = "0"
		api.alsa.card.longname = "HDA Intel PCH at 0x6001118000 irq 130"
		api.alsa.card.name = "HDA Intel PCH"
		api.alsa.path = "hw:0"
		api.alsa.use-acp = "true"
		device.api = "alsa"
		device.bus = "pci"
		device.bus_path = "pci-0000:00:1f.3"
		device.description = "Built-in Audio"
		device.enum.api = "udev"
		device.form_factor = "internal"
		device.icon_name = "audio-card-analog-pci"
		device.name = "alsa_card.pci-0000_00_1f.3"
		device.nick = "HDA Intel PCH"
		device.plugged.usec = "14831163"
		device.product.id = "0xf0c8"
		device.subsystem = "sound"
		sysfs.path = "/sys/devices/pci0000:00/0000:00:1f.3/sound/card0"
		device.vendor.id = "0x8086"
		device.vendor.name = "Intel Corporation"
		media.class = "Audio/Device"
		factory.id = "14"
		client.id = "35"
		object.id = "41"
		object.serial = "42"
		object.path = "alsa:pcm:0"
		alsa.card = "0"
		alsa.card_name = "HDA Intel PCH"
		alsa.long_card_name = "HDA Intel PCH at 0x6001118000 irq 130"
		alsa.driver_name = "snd_hda_intel"
		device.string = "0"

does aplay -l
show some info?

aplay -l output:

card 0: PCH [HDA Intel PCH], device 0: ALC897 Analog [ALC897 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 8: HDMI 2 [HDMI 2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 9: HDMI 3 [HDMI 3]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 10: HDMI 4 [HDMI 4]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

try this in terminal:

sudo modprobe snd_hda_codec
sudo modprobe snd_hda_intel
sudo modprobe snd_hda_intel_codec

and see if you have any change on dummy device to another codec

No change on the first two commands, but this one returns:

modprobe: FATAL: Module snd_hda_intel_codec not found in directory /lib/modules/5.19.1-arch2-1

i am clueless for now… only thing you could try is to install LTS kernel to see if it is kernel related…

or you could try to switch back to pipewire-media-session manager. Some users reported that they need it to get audio working fully…

yay -S pipewire-media-session
will replace wireplumber… after this remove configs again and reboot:
rm -R ~/.config/pulse ~/.local/state/wireplumber

to went back to wireplumber:

yay -S wireplumber
after this remove configs again and reboot:
rm -R ~/.config/pulse ~/.local/state/pipewire

and you could show the boot log:
journalctl -b -0
Could show error or warning about device or service…

also the full inxi output (inxi -Fxxxza --no-host) would help doing research-

Just to verify as I can’t see this in the thread, did you try changing “Off” to a different profile, e.g. “Analog Output” ?

1 Like