No sound and pavucontrol doesn't detect sound cards

Hi, since today I don’t have sound and pavucontrol doesn’t detect sound cards. I suspected it was the update of alsa-sound-cards who was the culprit but reverting to an older version did not help.
I also tried to reinstall the kernel but it did not help.

Kernel: 5.11.8-arch1-1
here’s an inxi output

┌─[xavierp@xavier-20l5cto1ww] - [~] - [Wed Mar 24, 09:35]
└─[$] <> inxi -F
System:    Host: xavier-20l5cto1ww Kernel: 5.11.8-arch1-1 x86_64 bits: 64 Desktop: KDE Plasma 5.21.3 Distro: EndeavourOS 
Machine:   Type: Laptop System: LENOVO product: 20L5CTO1WW v: ThinkPad T480 serial: <superuser required> 
           Mobo: LENOVO model: 20L5CTO1WW v: SDK0J40709 WIN serial: <superuser required> UEFI: LENOVO v: N24ET61W (1.36 ) 
           date: 10/13/2020 
Battery:   ID-1: BAT0 charge: 19.3 Wh condition: 20.3/23.9 Wh (85%) 
           ID-2: BAT1 charge: 57.5 Wh condition: 59.3/71.1 Wh (83%) 
CPU:       Info: Quad Core model: Intel Core i7-8550U bits: 64 type: MT MCP L2 cache: 8 MiB 
           Speed: 1900 MHz min/max: 400/4000 MHz Core speeds (MHz): 1: 1900 2: 1900 3: 1900 4: 1900 5: 1900 6: 1900 7: 1900 
           8: 1900 
Graphics:  Device-1: Intel UHD Graphics 620 driver: i915 v: kernel 
           Device-2: NVIDIA GP108M [GeForce MX150] driver: nvidia v: 460.67 
           Device-3: Acer Integrated IR Camera type: USB driver: uvcvideo 
           Device-4: Acer SunplusIT Integrated Camera type: USB driver: uvcvideo 
           Display: x11 server: X.Org 1.20.10 driver: loaded: intel,nvidia unloaded: fbdev,modesetting,vesa resolution: 
           1: 2560x1440~60Hz 2: 1440x2560~60Hz 
           Message: Unable to show advanced data. Required tool glxinfo missing. 
Audio:     Device-1: Intel Sunrise Point-LP HD Audio driver: snd_hda_intel 
           Device-2: Logitech HD Pro Webcam C920 type: USB driver: snd-usb-audio,uvcvideo 
           Device-3: Blue Microphones Yeti Stereo Microphone type: USB driver: snd-usb-audio 
           Device-4: Lenovo ThinkPad Thunderbolt 3 Dock USB Audio type: USB driver: hid-generic,snd-usb-audio,usbhid 
           Sound Server: ALSA v: k5.11.8-arch1-1 
Network:   Device-1: Intel Ethernet I219-V driver: e1000e 
           IF: enp0s31f6 state: down mac: 98:fa:9b:28:26:16 
           Device-2: Intel Wireless 8265 / 8275 driver: iwlwifi 
           IF: wlan0 state: up mac: 84:fd:d1:1e:71:7f 
           Device-3: Lenovo ThinkPad TBT 3 Dock type: USB driver: r8152 
           IF: enp9s0u2u1u2 state: down mac: 3c:e1:a1:c3:ae:e2 
           IF-ID-1: docker0 state: down mac: 02:42:7a:99:63:c5 
Bluetooth: Device-1: Intel Bluetooth wireless interface type: USB driver: btusb 
           Message: Required tool hciconfig not installed. Check --recommends 
Drives:    Local Storage: total: 931.51 GiB used: 159.15 GiB (17.1%) 
           ID-1: /dev/sda vendor: Samsung model: SSD 860 EVO 1TB size: 931.51 GiB 
Partition: ID-1: / size: 915.6 GiB used: 159.15 GiB (17.4%) fs: ext4 dev: /dev/dm-0 
           ID-2: /boot/efi size: 299.4 MiB used: 2.6 MiB (0.9%) fs: vfat dev: /dev/sda1 
Swap:      Alert: No Swap data was found. 
Sensors:   System Temperatures: cpu: 49.0 C mobo: 44.0 C 
           Fan Speeds (RPM): cpu: 2863 
Info:      Processes: 302 Uptime: 2m Memory: 31.25 GiB used: 3.37 GiB (10.8%) Shell: Zsh inxi: 3.3.01 
┌─[xavierp@xavier-20l5cto1ww] - [~] - [Wed Mar 24, 09:36]
└─[$] <> 

Have you uninstalled something recently?
A longshot, but a few things over the years have removed the pulseaudio package for me because it was a dependency for the thing I removed for some stupid reason.

Check if the package pulseaudio is installed.

No not that I remember, there was a big update yesterday.

I’m using pipewire not pulse.

1 Like

Ok so I solved it here are the step:

  1. Realise that last update might have broken something
  2. Look at pacman’s logs by using a random ide
vim /var/log/pacman.log
  1. Hunt down anything related to audio that were updated yesterday
[2021-03-23T21:16:28+0100] [ALPM] upgraded alsa-card-profiles 
[2021-03-23T21:16:41+0100] [ALPM] upgraded pipewire (1:0.3.23-1 -> 1:0.3.24-1)
[2021-03-23T21:16:41+0100] [ALPM] warning: /etc/pipewire/media-session.d/media-session.conf installed as /etc/pipewire/media-session.d/media-session.conf.pacnew
[2021-03-23T21:16:41+0100] [ALPM] upgraded pipewire-media-session (1:0.3.23-1 -> 1:0.3.24-1)
[2021-03-23T21:16:41+0100] [ALPM] upgraded pipewire-pulse (1:0.3.23-1 -> 1:0.3.24-1)
  1. Realise that somehow the pipewire or alsa update broke something
  2. Fix it by downgrading to the previous version using package downgrade
└─[$] <> sudo downgrade pipewire              

└─[$] <> sudo downgrade pipewire-media-session

└─[$] <> sudo downgrade pipewire-pulse    

└─[$] <> sudo downgrade alsa-card-profiles
  1. Reboot
  2. Pray

I have removed the different prompt you have to go through but you get the idea.

1 Like

I am running Xfce and switched to Pipewire today just because. Worked fine, but then 1. Xfce as I said, 2. The update in itself might be an issue, I installed the version fresh.

The real issue is you did not deal with the pacnew file. If you don’t deal with it next time you update it will break again.

[2021-03-23T21:16:41+0100] [ALPM] warning: /etc/pipewire/media-session.d/media-session.conf installed as /etc/pipewire/media-session.d/media-session.conf.pacnew

The welcome application has a button just for this purpose.

5 Likes

Maybe another sticky note about pipewire?

I think I need to make a couple. One for pacnew files and another for xf86-video-intel needing to be removed.

3 Likes

So I did what you were talking about but now should I upgrade or not ?

1 Like

You have to deal with the .pacnew, like here or here.

2 Likes

@csteinforth has given you a few good links. This thread also has a lot of information on how to deal with pacnew files. Sorry for the late reply I was driving home from work.

Or you can use the welcome app like so:

2021-03-24_15-56

3 Likes

OT: first timeshift and now welcome in dark and red :wink:

2 Likes

Thanks will try tomorrow !

2 Likes

I still don’t understand these pacnew files and what i’m supposed to do with them. I see pacnew all the time but have never done anything? :thinking: I run pacdiff and it shows nothing.

1 Like