No sound after x86_64 kernel upgrade from 5.5.9 to 6.6.1 on Lenovo laptop

After upgrade the linux kernel from 5.5.9 to 6.6.1, everything else works, except there is no sound from the laptop speakers. If I plug-in bluetooth headset, HDMI, or anything else, sound works perfectly. Only the speakers do not.
On visual monitor, there is sound to see, but no sound comes from the speakers. I have already installed sof-firmware and tried some other things, but nothing works… I also fresh installed whole Endeavouos Linux, but the problem is still there.
I think, the problem is in the new kernel that possibly doesnt support Lenovo laptop speakers…

If someone has any solution, I would be very greatfull to direct me to it. Laptop is Legion 7 16ACHg6, 82N6.

Well try an older kernel like LTS.

I tried and it works perfectly, every version till 6.6, but I would like to solve the problem on the new kernel, because I use some packages, that are bound to the new kernel…

Well, I think it’s safe to say that none of the volunteers at Endeavouros are actually kernel developers in disguise.
Perhaps this will be helpful:

1 Like

Thank you for your help dbarronoss, I tried without success and the problem is still there despite new kernel version (6.6.2).
I tried to send the message with bug report to different recipients but without success.
Here is the list, that I found searching the link that dbarronoss provided and some google research:

Please, does someone have any email from LINUX KERNEL developers, because 6.6.3 version doesn’t work also… I am considering now to change the distro… I really love my laptop. It is powerfull and GPU has 16Gb of DDR, which I need for conversation with LLM models. Cant use speech chat with AI with my laptop without external speakers or my earpods… sad…