No sound after the recent update

Hello
After the endeavouros update which replaced Pipewire-Media-Session with Wireplumber, I am having no sound. I masked wireplumber to fix the issue for now.
Is this permanent fix? Or it would break with some other update in the future?

I saw this arch linux forum and tried installing pipewire-pulse. But I can’t install it on edeavouros as it conflict with some other dependency that can’t be removed.

How to fix this issue?
Thread link: https://bbs.archlinux.org/viewtopic.php?id=276298

What DE are you using?
Some DEs like Gnome and KDE have pipewire components as dependencies.

If yours is not one that depends on pipewire, you might want to stick with pulseaudio.

At any events, looks like pipewire is not quite fully installed on your system.

You could try removing pulseaudio-jack first.
Post any warnin/error messages to the forum.

Please refer to relevant articles in EnOS’ wiki for more info:

https://discovery.endeavouros.com/?s=pipewire

PS- Please post the terminal output as text. Copy, paste, highlight and click on </> button to format.

2 Likes

Thanks @pebcak
that seems to have fixed it.
This is what I did:

$ sudo pacman -Rs pulseaudio-jack
$ sudo pacman -S pipewire pipewire-alsa pipewire-jack pipewire-pulse gst-plugin-pipewi
re wireplumber

It removed pipewire entirely I think. And I am using gnome.
I have unmasked the wireplumber service.
This is the output of pactl info

$ pactl info
Server String: /run/user/1000/pulse/native
Library Protocol Version: 35
Server Protocol Version: 35
Is Local: yes
Client Index: 82
Tile Size: 65472
User Name: yashrathi
Host Name: yashrathi
Server Name: PulseAudio (on PipeWire 0.3.51)
Server Version: 15.0.0
Default Sample Specification: float32le 2ch 48000Hz
Default Channel Map: front-left,front-right
Default Sink: alsa_output.pci-0000_00_1f.3.analog-stereo
Default Source: alsa_input.pci-0000_00_1f.3.analog-stereo
Cookie: c931:dacb
3 Likes

Looks good!
Glad you got it resolved!

:enos_flag:

2 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.