No screens after boot


Today I booted into my OS but only one of my monitors was on I updated the system and rebooted to see if the issue went away. However, after the reboot there were no monitors. After logging into the tty I got this output when trying to start x server.

Is this normal?(errors regarding x not found) I believe that x should be present. I use i3 but I don’t think that is relevant.


Ps I get through the entire boot process correctly but when I have to enter the display manager to log in my monitors start flashing in grey.

there is error on mirrors , can you recheck before ,
remove any lock and confirm update ending ?


I changed the command to update mirrors and it worked. But I still have the same issue.



This is message I get after looking for xorg and xorg-init in the system.

After installing xterm starts works.

I have managed to start i3 also.

But for most applications there is a error: error loading shared libraries file too short.

After rebooting the problem still persists.



It seems the main issue is the . When trying to run libre wolf it also triggers a error.

Attempting to reinstall libtiff doesn’t work.

Solved libtiff issue using pacman -S —dbonly and later pacman-S

The os looks like it is completely corrupted. :frowning: