No remote input with kdeconnect

When I pair my phone and laptop with kdeconnect everything works except the remote input. (It does work with another laptop which runs lxqt.)

There are a few reddit posts of other people having this problem with no solutions except possible installed xdg-desktop-portal with the kde backend.

I already had xdg-desktop-portal with the wl-roots backend installed and adding the kde backend did not fix anything.

According the arch wiki entry it is a common issue that xdg-desktop-portal does not start automatically under sway, however I’m not sure if this is the case.
The systemd service is running but the XDG_CURRENT_DESKTOP variable is not set automatically (even if I boot with include /etc/sway/config.d/*).
Manually adding it to the systemd environment also does not fix the issue.
xdg-desktop-portal and the the backends are also not in my systems PATH, I don’t know if they are supposed to be but the github page of the wlr backend seems to suggest they should be.

Not sure where to go from here. Is there anything glaringly wrong about my set-up based on what I wrote here?

1 Like

I could not find that suggestion. You may have misunderstood something, or explain more.

How and when do you check? sway wiki (your link) assures it is set.

Read and inspect system logs. There is no other way to find a bug, if there is any.

I have no sway experience, but what you have described suggest a good configuration, but you did not explain and post details, like what commands, what file contents, etc.

OTOH, have you searched, or asked upstream kdeconnect bug tracker, for similar existing bugs, or advice?

I not entirely sure if you actually can.

It appears it is still being worked on.

The wlr backend github pages says

To list the available options, you can run xdg-desktop-portal-wlr --help.
and has another example xdg-desktop-portal-wlr being used as a command, that is what made me think it should maybe be in the PATH.

I checked for the variable being set with systemctl --user show-environment and echo $XDG_CURRENT_DESKTOP. After reboot it doesn’t show with either.

I haven’t checked the kdeconnect bug tracker (though if I remember correctly there was a similar github issue that was resolved in a way that didn’t help me). Will check that out.

Also thanks for the suggestion to check logs lol (should’ve thought of that). journalctl actually shows an error (which is good 'cause I don’t know many other place to check logs lol).

kdeconnectd[1029]: QDBusConnection: error: could not send message to service "org.freedesktop.portal.Desktop" path "/org/freedesktop/portal/desktop" interface "org.freedesktop.portal.RemoteDesktop" member "NotifyPointerMotion": Marshalling failed: Invalid object path passed in arguments

Not sure what that means, but seems promising. (This happens when I try to move the move the mouse using the remote input from kdeconnect).

you did not explain and post details, like what commands, what file contents, etc.
Tbh I mentioned everything that I thought was related. But since you said commands maybe it wasn’t clear what I’m trying to do. I run kdeconenct on laptop and phone and they are paired, no commands are being issued, I just try to use the remote input feature and nothing happens.

Thanks, that does indeed sound like it might be impossible at the moment :frowning:

Maybe I’ll just have to follow that PR and wait.

Strange though, some comments I saw during my search definitely seemed like they got it working.

1 Like