No network linux-zen linux-xanmod

Hello eos community. After installing linux-xanmod and updating grub I boot into eos to discover I have no network service. Booting back into linux kernel my ethernet connection is fine. I tried linux-zen with same results. I am sure I’m missing a step somewhere. Mash anyone help me as to how to proceed?

depend yous lspci which network driver you use. if you used driver only need for linux then it dont work, you need a dkms dependable which network chip you use

1 Like

My guess is that you need to uninstall the r8168 package, which comes installed by default on EndeavourOS, but is not needed in a vast majority of cases. I could be wrong, of course, but this is worth trying, because it’s so simple.

Run:

sudo pacman -R r8168

Reboot and see whether you get the network connection for those unofficial kernels.

If that doesn’t get you your network connection then you’ll have to install the dkms driver for your specific network card.

2 Likes

Hmm,
When I switched from standard to Zen I lost network connection temporarily, but after a reboot it came back without reinstalling anything.

1 Like

Added to @Kresimir post - DKMS drivers? If yes. Then you need the kernel headers.

4 Likes

What does this show:

  pacman -Q linux-zen-headers linux-xanmod-headers
  lspci -vnn | grep -i ethernet
1 Like

Thank you thank you for all of your replies! I will follow up as soon as I finish work! I appreciate all the help and support

Yes I rebooted after seeing no network and it was still disconnected. I installed the headers for zen and xanmod also. I have an ethernet connection

What command do I run to get the name of my network card? So I know which dkms driver to install?

Do you have inxi installed?

inxi -N
Network:   Device-1: Intel Wireless 7260 driver: iwlwifi
           Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: N/A

I’d first try just removing r8168 and rebooting, to see if that is enough. If you’re lucky you won’t need to do anything else.

2 Likes

Wow thank you very very much! Removing the r8168 package worked. After removing it I rebooted back into my system and I have internet connection

2 Likes

yeah , removing it can but personal would not say it directly since on our side don’t know what chipset it is :slight_smile:
in some cases you can loose totaly internet. thats why like @xircon show the the device :slight_smile:

1 Like

A good idea would be to mark Kresimir’s suggestion as the Solution so others searching this forum later can find it easily. :slight_smile:

2 Likes

Thank you I will do that.

3 Likes

Got a new Zen kernel today and no network until I booted into the standard kernel. r8168 is NOT installed.

I have a shell script in my home folder that I run whenever this happens to me, and it happens after almost every kernel upgrade, but not all. This takes care of the issue:

#!/bin/bash
sudo sed -i /usr/lib/modprobe.d/r8168.conf -e 's|r8169|r8168|'
sudo modprobe -r r8169 && sudo modprobe r8169
3 Likes

Wireless works fine with the Zen kernel, oddly.

I think I installed r8168-dkms from AUR and it fixed it.