No more GUI with Zen-Kernel


Since this Weekend, I can’t use anymore my PC in GUI Desktop (KDE) mode with the Zen-kernel…

Dracut stay frozen on the state : [OK] Reached target graphical interface.
And no more happens. (I can quickly listen my HDD to work, so I suppose KDE is waiting for SDDM login in background…)

Tried new update of today > No differences.
Tried to uninstall and reinstall the Zen-Kernel with GRUB update both of time > No differences.

Still cannot use GUI mode with the Zen one.

And now I’m lost xD (Sorry, not an Linux Expert)

Sorry : Forgotten the Inxi here it is : MyInxi

If anybody had some time to help me, I will be gratefull =)

Thanks a lot !

Are you using an nvidia GPU?

If so, you need to ensure you have linux-zen-headers and nvidia-dkms installed.

1 Like

Yes Nvidia RTX-2700 GPU (forgotten the Inxi in my first post, sorry)
And Pacman tells me both of them are installed.

Well, if you think it’s the zen kernel then install some other kernel, perhaps the LTS.

Of course i’ve both Zen and LTS installed.
Here i’m on LTS so I can keep using my computer (You can see this actually in my Inxi :slight_smile: )

I didn’t look at it :wink:
But anyway, you’re where I’ve been with zfs on occassion, wait for it to be identified and fixed, and run lts for a while :wink:
Good chance it’ll be fixed in the next release…

With no response, I’ve used my backup created on May with Redo, full upgraded system and restoring my /home with timeshift, and now everything is fine :wink:

Sorry for bother, Just trying to learn :wink:

See ya pals :wink:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.