No Mans' Sky on Laptop Borked

So I’ve got no clue how one troubleshoots this one…

I have a desktop and laptop both running identical installs of EndeavourOS. I recently (finally) decided to give NMS a go since it was on sale a week or so ago and have fallen in love with it! It runs much better on my desktop but sometimes I wanna play when I’m on the couch or away from home.
Anywho, the most recent batch of updates that came down the pipeline seems to have selectively broken NMS exclusively on my laptop. Meaning that it runs beautifully on desktop, and all my other known-good proton games run fine on my laptop, but NMS says that I don’t have vulkan something or other. See the VulkanNMSError

This error is discussed on the various NMS forums, but the solution - specific to windows - seems to be reinstall geforce experience after using ddu to clean your current driver install.

I have rolled back my OS and tried reupdating but this issue exists no matter what, so this is not just a bad driver, something else has gone wonky with whatever vulkan updates came down the pipeline in the last 4 or 5 days…

Hey! :slight_smile:

  1. Post your hardware info:

    inxi -Fxxxz
  2. Is it Steam or Retail version of game with Wine?

  3. Do you launch it with Lutris or directly (if directly - do you use dxvk)?

  4. Make sure you have read requirements section

  1. Hardware, check!
System:    Kernel: 5.9.6-arch1-1 x86_64 bits: 64 compiler: gcc v: 10.2.0 Desktop: KDE Plasma 5.20.3 tk: Qt 5.15.1 wm: kwin_x11 
           dm: LightDM 1.30.0 Distro: EndeavourOS 
Machine:   Type: Laptop System: LENOVO product: 80NV v: Lenovo ideapad Y700-15ISK serial: <filter> Chassis: type: 10 
           v: Lenovo ideapad Y700-15ISK serial: <filter> 
           Mobo: LENOVO model: Allsparks 5A v: SDK0J40709 WIN serial: <filter> UEFI: LENOVO v: CDCN53WW date: 09/19/2016 
Battery:   ID-1: BAT0 charge: 45.1 Wh condition: 48.5/60.0 Wh (81%) volts: 15.9/15.0 model: SANYO L14S4P22 type: Li-ion 
           serial: <filter> status: Discharging 
           Device-1: hidpp_battery_0 model: Logitech Marathon Mouse/Performance Plus M705 serial: <filter> 
           charge: 100% (should be ignored) rechargeable: yes status: Discharging 
CPU:       Info: Quad Core model: Intel Core i7-6700HQ bits: 64 type: MT MCP arch: Skylake-S rev: 3 L2 cache: 6144 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 41621 
           Speed: 800 MHz min/max: 800/3500 MHz Core speeds (MHz): 1: 800 2: 800 3: 801 4: 800 5: 800 6: 800 7: 800 8: 800 
Graphics:  Device-1: Intel HD Graphics 530 vendor: Lenovo driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:191b 
           Device-2: NVIDIA GM107M [GeForce GTX 960M] vendor: Lenovo driver: nvidia v: 455.38 bus ID: 01:00.0 
           chip ID: 10de:139b 
           Device-3: Acer Lenovo EasyCamera type: USB driver: uvcvideo bus ID: 1-6:3 chip ID: 5986:0672 serial: <filter> 
           Display: x11 server: X.Org 1.20.9 compositor: kwin_x11 driver: intel unloaded: fbdev,modesetting,vesa 
           resolution: 1920x1080~60Hz s-dpi: 96 
           Message: Unable to show advanced data. Required tool glxinfo missing. 
Audio:     Device-1: Intel 100 Series/C230 Series Family HD Audio vendor: Lenovo driver: snd_hda_intel v: kernel 
           bus ID: 00:1f.3 chip ID: 8086:a170 
           Sound Server: ALSA v: k5.9.6-arch1-1 
Network:   Device-1: Intel Wireless 8260 driver: iwlwifi v: kernel port: 4000 bus ID: 08:00.0 chip ID: 8086:24f3 
           IF: wlan0 state: up mac: <filter> 
           Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Lenovo driver: r8168 v: 8.048.03-NAPI 
           port: 3000 bus ID: 09:00.0 chip ID: 10ec:8168 
           IF: enp9s0 state: down mac: <filter> 
Drives:    Local Storage: total: 1.03 TiB used: 644.42 GiB (61.3%) 
           ID-1: /dev/sda vendor: Samsung model: MZNLN128HCGR-000L2 size: 119.24 GiB speed: 6.0 Gb/s serial: <filter> 
           rev: 3L0Q scheme: GPT 
           ID-2: /dev/sdb vendor: Western Digital model: WD10SPCX-24HWST1 size: 931.51 GiB speed: 6.0 Gb/s rotation: 5400 rpm 
           serial: <filter> rev: 1A02 scheme: GPT 
Partition: ID-1: / size: 107.92 GiB used: 66.37 GiB (61.5%) fs: ext4 dev: /dev/sda2 
Swap:      ID-1: swap-1 type: partition size: 8.80 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/sda3 
Sensors:   System Temperatures: cpu: 32.0 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Info:      Processes: 239 Uptime: 52m Memory: 15.47 GiB used: 3.44 GiB (22.2%) Init: systemd v: 246 Compilers: gcc: 10.2.0 
           Packages: pacman: 1364 Shell: Bash v: 5.0.18 running in: yakuake inxi: 3.1.08
  1. Steam version, running Proton 5.13-1 but also tried 4.11 and GE 5.9-something

  2. Running directly from steam, not specifically running dxvk but the game works perfectly fine pre-OS-update and gives me that error post-OS-update. All other games work fine.

  3. I’ve got a compatible GPU, nvidia utils and such installed, vulkan icd and the other one are installed, protonDB says the game is gold and I know that it works under all the various proton versions both from past experience on my laptop and because I can still play without a hitch on desktop


Is this Lenovo model use only dedicated Nvidia GPU without Optimus and all that crap, rght?

First of all, since Nvidia for now doesn’t officially support Kernel 5.9, please try LTS Kernel and see maybe this is a problem (not likely, but still worth a shot)

Then also see if there are no errors in journal:

journalctl -p3 -xb

And then also let’s see the logs:

Launch game and it will be saved at your home, perhaps something useful will come out…

Oops, missed Intel part…So it’s Optimus :woozy_face:
How you’ve installed drivers?

We need to make sure you’re running Nvidia when launching game, i’m not a fan of it and haven’t yet mentioned in guide, but it’s fastest way to make sure:

Feral interactive GameMode

Game Mode set your CPU governor to max performance while you are playing, and can improve FPS in some cases. It’s automatically enabled for all your games when you have game mode installed on your system.

sudo pacman -S gamemode

It should automatically force Nvidia card when launching game

I did not specifically set up Optimus; in fact, I actually left Manjaro because their gpu switching stuff just caused such nightmares and I could never work around it and force only the discrete card to be used. When I installed EndeavourOS, I simply just installed the nvidia 4.xx drivers plus nvidia-utils and never looked back…

As for the journalctl, this is what I get:

-- Logs begin at Tue 2020-08-18 21:56:16 EDT, end at Wed 2020-11-11 12:22:21 EST. --
Nov 11 11:00:20 PhantomVoyager kernel: platform MSFT0101:00: failed to claim resource 1: [mem 0xfed40000-0xfed40fff]
Nov 11 11:00:20 PhantomVoyager kernel: acpi MSFT0101:00: platform device creation failed: -16
Nov 11 11:00:20 PhantomVoyager systemd-modules-load[259]: Failed to find module 'platform-integrity'
Nov 11 11:00:21 PhantomVoyager systemd-udevd[289]: could not read from '/sys/module/pcc_cpufreq/initstate': No such device
Nov 11 11:00:22 PhantomVoyager kernel: Bluetooth: hci0: Failed to send firmware data (-38)
Nov 11 11:00:28 PhantomVoyager lightdm[971]: gkr-pam: unable to locate daemon control file
Nov 11 11:00:31 PhantomVoyager kernel: Bluetooth: hci0: Reading supported features failed (-16)
Nov 11 12:17:31 PhantomVoyager kernel: Bluetooth: hci0: Failed to send firmware data (-38)
Nov 11 12:17:40 PhantomVoyager kernel: Bluetooth: hci0: Reading supported features failed (-16)

That bluetooth error is something that I have had issues with on this laptop even back in manjaro… my ps4 controller likes to hard-crash my system :roll_eyes:

I’m trying out the GameMode over lunch break, we’ll see what happens!

1 Like

That’s pretty unusual that your laptop allowed that, probably very good UEFI/BIOS if you have discrete GPU only switch in there

In journal nothing too out there…Well first 2 i’d try to fix, but it shouldn’t affect games anyhow

Sure, and don’t forget game’s log from Steam as well, that might help :wink:

So here is what I have installed, and sure enough, prime is there somehow… When I installed the drivers initially all I did was: sudo pacman -S nvidia nvidia-utils nvidia-settings So I have no idea how it pulled down and set up prime lol.

Gamemode seemed to just expedite the process of not working haha. Instead of getting the vulkan error, steam simply shows the game as launching… then straight back to the green “play” button.

I have the logs, not sure what I was hoping to find, but what I did get was beyond my comfort level of trying to read through :sweat_smile:

If it wasn’t try it. last resort try 5.9-GE-5–ST

1 Like

I don’t think it’s Wine / Proton, but who knows…

Looks like driver / vulkan issue to me, Proton / Vulkan / DXVK doesn’t seem to understand your hardware:

5855.790:00c8:00cc:err:vulkan:wine_vk_instance_load_physical_devices Failed to enumerate physical devices, res=-3
5855.790:00c8:00cc:err:vulkan:wine_vkCreateInstance Failed to load physical devices, res=-3

Since your Nvida card supports Vulkan, it should be some mess with drivers.

I’d start from scratch:

  1. Use LTS Kernel for full Nvidia support
  2. Follow that guide for proper driver management with Optimus, it’s the best way to have sanity:

But before that, just please make sure again that you have all those packages installed:

sudo pacman -S vulkan-icd-loader lib32-vulkan-icd-loader vulkan-icd-loader lib32-vulkan-icd-loader

And try again

Which is weird since you say that other games played well, but…Well what can i say - something is certainly wrong :upside_down_face:

There was a vulkan update recently that did some odd things.


Ok it may be just that, but here we’re helpless until it fixed then :frowning:
Probably hardware specific oddities…

P.S. btw i still can’t run Red Dead Redemption 2, so probably it’s exactly that :laughing:

Ah it’s good to hear that it might not just be something dumb on my end! lol

I’m going to try reinstalling vulkan macguffins, and if that doesnt do anything maybe just roll back to pre-update functionality and then hand pick packages to update and try to isolate which one specifically caused the problem


Okay! Wild update!
So following your suggestion to doublecheck vulkan with:

sudo pacman -S vulkan-icd-loader lib32-vulkan-icd-loader

I ran that on the terminal and got the “Warning already up to date” so they’re definitely installed. But what could it hurt, I let it just reinstall for giggles. Well… a quick re-log later and NMS launched just like it used to!

Yay, right? Well now that I’ve fixed it I should finally allow my system to update and get all the outstanding patches/fixes/etc. The list of updates had nothing to do with vulkan, just a minor kernel update, some random system packages, ixni, nothing wild. Go figure after updating I’m back to the same error! Even though vulkan wasn’t messed with in the updated packages!
Well with nothing to lose I re-reinstalled vulkan and lib32-vulkan and bam! Worked a second time.

So apparently whatever update was made to vulkan last week now craps itself when you update anything else on your system lol. What a weird issue.


Told ya :upside_down_face:


Well…Since it’s vulkan crapped itself, i probably should try same to see if it helps me launch RDR2, coz lots of other people seem to play it fine :slight_smile: (just tested - nope :confused: )

P.S. Maybe reason is Kernel / Nvidia modules while update crapping vulkan somehow
@jonathon @anon31687413 maybe you have some ideas why or where should it be reported?

Whelp, this issue is back again and no longer can be solved with a reinstall of vulkan :roll_eyes: