No man's sky is absurdly slow, so slow I can't even get out of a loading screen

Interesting I am running it natively so no proton needed.

Wait, what? No man’s sky? Natively?

1 Like

Nah, check this


On the steam client, top left, click steam → Settings → steam play

The one you posted is to force a specific proton version for a title, or to force a title to use the windows version. I play borderland 2 windows version for instance because for some reason it runs better than the linux version, and has more DLC.

Those are global settings, he means per-game setting, click right mouse button on game

Oh that’s right I forgot i set that: So 6.3-7

Yes, I know, but if the game doesn’t have specific settings it uses the global settings, no man’s sky doesn’t have a native linux version.

It sure would’ve been awesome to have it run natively.

1 Like

Proton experimental is really only for a handful of games.

Yeah, but I really use compatibility for each specific title. In NMS case I tried quite a few different versions of proton. On mint it runs perfectly with 4.11-13 on my pc, other versions won’t let me use multiplayer.

On my endeavour installation it just… Well, you know.

Maybe I can fetch some data from my mint installation to figure out what might be different? What would I have to find?

So, my wild guess is that maybe the gpu drivers are not working as well as they could, so I went and checked the arch wiki about it.
I found this: https://wiki.archlinux.org/title/AMDGPU#Loading
Si U went and checked /etc/mkinitcpio.conf and, under modules, there’s nothing. The line just says MODULES=""
I didn’t edit anything just yet because I’m not sure if I should.
I also checked /etc/X11/xorg.conf.d/20-amdgpu.conf but the file doesn’t exist. Again I didn’t edit anything, because I don’t know if the wiki is outdated or something, so before progressing further I’ll check here for opinions.

20-amdgpu doesn’t exist on default and isn’t needed.

You also shouldn’t need mkinitcpio edits as RDNA GPU use amdgpu driver on default.

I noticed you have a black magic card. You don’t happen to be using workarounds to run davinci with the radeon-pro driver? I notice ati is also loaded not just amdgpu

NMS likes RADV, Running from an SSD, and Proton 4.11-13.

BTW after you first run it with 4.11 you can swap to newer proton and MP works. Its just fails to install needed bit if run with 5.0+ first

Yeah its not native, but hello games does do proton specific fixes when needed which is great

So, got it running, I didn’t think to come here to update because the interest seemed to be fading and didn’t think there would be interest.

To answer your posts Echoa: Yeah I do have a black magic, but I don’t use davinci, not yet at least, I may have to if I decide to edit videos. Unless there’s better options.
So no workaround there.
The problem in the end of the day was the drivers. I solved it by adding the following line:
AMD_VULKAN_ICD=RADV %command%
To the launch options of the game.
I ended up uninstalling the other drivers, here’s hoping it wasn’t a mistake but so far so good.

BTW after you first run it with 4.11 you can swap to newer proton and MP works. Its just fails to install needed bit if run with 5.0+ first

Oh that’s cool, I didn’t realize. I’ll switch to a newer version then, thanks!

If you had any of the proprietary andgpu/amdgpu-pro bits installed that would be necessary. If not its supposed to use radv on on default