No Longer able to Change Brightness on Laptop w/ Keybinds

I have a lenovo thinkpad x13 gen 3 with i3wm and the brightness would change when pressing the brightness keys on the keyboard which are F5 and F6. When I press those my mouse turns into an infinite loading when not hovering on a window so like on the background. I installed brightnessctl and it lets me change the brightness when setting the brightness via the command line like brightnessctl set 100. It used to work before. All other F keys work except F4 which is the mic mute button which may or may not have worked before, I don’t use it much.

What desktop environment is in use?

i3wm as stated.

You will have to find the binding in your config (looks like bindsym XF86MonBrightnessUp exec brightnessctl -c backlight set +5% or similar) and update it to whatever configuration works for your machine.

I’m not sure why, but this seems to be an ongoing thing for i3. There are quite a few topics in the forum with this same issue; see for yourself:

It seems different things work for different people; you’ll have to do some testing and figure out what works in your specific setup.

I have the same problem with the same hardware :sweat_smile:

It was working for a while but it looks like something broken it in the last time.

The i3 config from endeavouros uses (as default) a own script “”

When I execute the command I receive following error:

> $ xbacklight -inc 2.5 -time 0                                                                                                                               
No outputs have backlight property

So far I could not fix it but honestly I did not really invested much time till now.

instead of xbacklight I am using brightnessctl after reading:

You should simply not use xbacklight but any of the other alternatives that are more intelligent in what they do. xbacklight explicitly relies on a functionality of xf86-video-intel that isn’t replicated in any other driver, but there’s no technical reason for this dependency to exist. acpilight provides ab xbacklight drop in binary while being able to directly adjust the relevant backlight control file regardless of the xorg driver in use.


So I changed in the script ~/.config/i3/scripts/
the following lines:

function get_brightness {
    brightnessctl | grep -Po '[0-9]{1,3}'| sed -n '3p' 
    # Increases brightness and displays the notification
    brightnessctl set "10%+"

    # Decreases brightness and displays the notification
    brightnessctl set "10%-"

now it works again like before.
Should work for you @zangoku as well after you installed brightnessctl.