No internet on first boot on i3wm

I can’t connect to the Internet after installing the net install of i3wm. I have tried iwctl to connect to my WiFi but it constantly waits for the iwd daemon. Since I only have one device (laptop), I had no choice but to install Linux Mint for the meantime to use my laptop.
Tips or suggestions appreciated. :smile:

BTW, I really wanted to use Arch + i3wm and I think EOS is a great way to get started. I have tried Manjaro but it feels bloated and I really appeciate Arch’s swift package system.

1 Like



This might be covered by a recent post:


Seeing the author of the linked post, I know you are in very good hands with the issue you are having, so I’ll just say welcome to the community :beers:


Thank you! I will try the attached solution. And if problems persist, I’ll have the forum by my side. :heart:

I’m sorry to bother you but in the attached walkthrough video, EOS was installed in a virtual machine and the internet (through the ethernet) was automatically set up, whereas I do not have an ethernet connection to my home’s WiFi router. What do you propose to do in my situation? Thanks again.

1 Like

It shouldn’t make any difference - if you have wifi in the live installer then it should work in the installed OS too, it just needs the correct software to be installed.

You might also consider getting hold of an Ethernet cable as it can make things way easier when wifi has issues.

But, it’s probably worth describing what you installed, what you have tried, and what hardware you have (e.g. output of inxi -Fxxxz).

1 Like

@jonathon I also noticed that when entering “ifconfig” on the teminal, only “enp2s0f1” and “lo” are seen and “wlp3s0” is missing.

These were one of the last things I did before installing LM.

This is what I have on my LM install. Hope this helps.

sky@sky-pc:~$ inxi -Fxxxz
System:    Kernel: 5.4.0-26-generic x86_64 bits: 64 compiler: gcc v: 9.3.0 Desktop: Xfce 4.14.2 tk: Gtk 3.24.13 
           info: xfce4-panel wm: xfwm4 dm: LightDM 1.30.0 Distro: Linux Mint 20 Ulyana base: Ubuntu 20.04 focal 
Machine:   Type: Laptop System: Acer product: Aspire A315-41G v: V1.18 serial: <filter> 
           Mobo: RR model: Metapod_RR v: V1.18 serial: <filter> UEFI: Insyde v: 1.18 date: 06/18/2020 
Battery:   ID-1: BAT1 charge: 5.6 Wh condition: 19.7/36.7 Wh (54%) volts: 10.2/11.3 
           model: LG 0x41,0x43,0x31,0x34,0x42,0x31,0x0003 type: Li-ion serial: <filter> status: Discharging 
CPU:       Topology: Quad Core model: AMD Ryzen 5 2500U with Radeon Vega Mobile Gfx bits: 64 type: MT MCP 
           arch: Zen L2 cache: 2048 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 31938 
           Speed: 1368 MHz max: 1600 MHz boost: enabled Core speeds (MHz): 1: 1368 2: 1369 3: 1453 4: 1418 
           5: 1368 6: 1368 7: 1491 8: 1516 
Graphics:  Device-1: AMD Raven Ridge [Radeon Vega Series / Radeon Vega Mobile Series] 
           vendor: Acer Incorporated ALI driver: amdgpu v: kernel bus ID: 04:00.0 chip ID: 1002:15dd 
           Display: x11 server: X.Org 1.20.8 driver: amdgpu,ati unloaded: fbdev,modesetting,vesa 
           resolution: 1920x1080~60Hz 
           OpenGL: renderer: AMD RAVEN (DRM 3.35.0 5.4.0-26-generic LLVM 10.0.0) v: 4.6 Mesa 20.0.8 
           direct render: Yes 
Audio:     Device-1: Advanced Micro Devices [AMD/ATI] Raven/Raven2/Fenghuang HDMI/DP Audio 
           vendor: Acer Incorporated ALI driver: snd_hda_intel v: kernel bus ID: 04:00.1 chip ID: 1002:15de 
           Device-2: Advanced Micro Devices [AMD] Family 17h HD Audio vendor: Acer Incorporated ALI 
           driver: snd_hda_intel v: kernel bus ID: 04:00.6 chip ID: 1022:15e3 
           Sound Server: ALSA v: k5.4.0-26-generic 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Acer Incorporated ALI 
           driver: r8169 v: kernel port: 2000 bus ID: 02:00.1 chip ID: 10ec:8168 
           IF: enp2s0f1 state: down mac: <filter> 
           Device-2: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter vendor: Lite-On 
           driver: ath10k_pci v: kernel port: 2000 bus ID: 03:00.0 chip ID: 168c:0042 
           IF: wlp3s0 state: up mac: <filter> 
Drives:    Local Storage: total: 931.51 GiB used: 11.67 GiB (1.3%) 
           ID-1: /dev/sda vendor: Seagate model: ST1000LM048-2E7172 size: 931.51 GiB speed: 6.0 Gb/s 
           rotation: 5400 rpm serial: <filter> rev: SDM1 scheme: GPT 
Partition: ID-1: / size: 915.40 GiB used: 11.66 GiB (1.3%) fs: ext4 dev: /dev/sda2 
Sensors:   System Temperatures: cpu: 43.6 C mobo: N/A 
           Fan Speeds (RPM): N/A 
           GPU: device: amdgpu temp: 40 C device: amdgpu temp: 43 C 
Info:      Processes: 272 Uptime: 10h 50m Memory: 14.62 GiB used: 2.46 GiB (16.8%) Init: systemd v: 245 
           runlevel: 5 Compilers: gcc: 9.3.0 alt: 9 Shell: bash v: 5.0.17 running in: xfce4-terminal inxi: 3.0.38 

always the trouble on r8168 & r8169 series
if r8168 is blacklisted , it will try with r8169
if 8169 is blacklist , it will try with 8168

you are depending in stable beween kernel and version linux-firmware for r816*

Oof :cry:
Do you have any suggestions?

Can you please explain? I cannot understand what you mean…

see this

and this

1 Like

I think the issue is with connecting to wifi rather than Ethernet.

Regarding your previous comment about using a wired connection, I can’t find an RJ-45 cable in the house.
But still, it leaves me wondering how the WiFi driver(??) is gone at first boot since I can connect through WiFi through the ISO. Damn…

This probably means it’s not the driver. I think the ISO uses Network Manager, so if you installed a different connection tool you’ll have to make sure it’s configured and running.

1 Like

You can also use Android USB phone tethering for a temporary internet connection if Ethernet is not an option.

I would try masking IWD, and install wpa_supplicant (just in case that is part of the issue). I far prefer iwd, but some people have been having problems with it recently.

You may want to run some ping tests to see if your dhcp setup is part of the problem. Ping Google by both its name and server address to see if you can get a positive response from one or the other.

 ping -c5
 ping -c5 

Post the results please.

1 Like

Oh yeah, there were some times where I have problems regarding dhcpcd. When I ping, it returns but does not. What does it mean?

Post the results please.

I cannot post the results per se (I have to install EOS on bare metal and if it fails, I have to reinstall LM), but I can remember it, or write the steps down before posting it on the forum again. So yeah, this little maneuver is gonna cost me 51 years. :cry:

I will try to use nmcli. Thanks for the suggestion.

1 Like

That generally indicates you have a DNS problem.