No internet connection

I’ve just installed Endeavouros and i haven’t been able to connect to internet both during live boot and after installation. I can connect to internet using USB tethering on my phone so i tried toggling between r8168 and r8169 drivers but both of them didn’t work. I tried installing Manjaro OS and i wasn’t able to connect to internet there either

Is there anyway for me to fix this?

Can you share the output of inxi -Fxxxz so we can see what specific hardware you have?

This is from live OS

Kernel: 5.15.8-arch1-1 x86_64 bits: 64 compiler: gcc v: 11.1.0
Desktop: Xfce 4.16.0 tk: Gtk 3.24.29 info: xfce4-panel wm: xfwm 4.16.1
vt: 1 dm: LightDM 1.30.0 Distro: EndeavourOS base: Arch Linux
Type: Desktop Mobo: Micro-Star model: B450 TOMAHAWK MAX (MS-7C02) v: 1.0
serial: UEFI: American Megatrends LLC. v: 3.B0
date: 05/12/2021
Info: 6-core model: AMD Ryzen 5 3600 bits: 64 type: MT MCP smt: enabled
arch: Zen 2 rev: 0 cache: L1: 384 KiB L2: 3 MiB L3: 32 MiB
Speed (MHz): avg: 2456 high: 3599 min/max: 2200/4208 boost: enabled
cores: 1: 2197 2: 2102 3: 2053 4: 2058 5: 2057 6: 3599 7: 3597 8: 2054
9: 2056 10: 2056 11: 2052 12: 3592 bogomips: 86426
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Device-1: NVIDIA TU116 [GeForce GTX 1660 Ti] vendor: Micro-Star MSI
driver: nvidia v: 495.46 bus-ID: 26:00.0 chip-ID: 10de:2182 class-ID: 0300
Display: server: X.Org compositor: xfwm4 v: 4.16.1 driver:
loaded: nvidia unloaded: modesetting alternate: fbdev,nouveau,nv,vesa
resolution: 1920x1080 s-dpi: 96
OpenGL: renderer: NVIDIA GeForce GTX 1660 Ti/PCIe/SSE2
v: 4.6.0 NVIDIA 495.46 direct render: Yes
Device-1: NVIDIA TU116 High Definition Audio vendor: Micro-Star MSI
driver: snd_hda_intel v: kernel bus-ID: 26:00.1 chip-ID: 10de:1aeb
class-ID: 0403
Device-2: AMD Starship/Matisse HD Audio vendor: Micro-Star MSI
driver: snd_hda_intel v: kernel bus-ID: 28:00.4 chip-ID: 1022:1487
class-ID: 0403
Sound Server-1: ALSA v: k5.15.8-arch1-1 running: yes
Sound Server-2: JACK v: 1.9.19 running: no
Sound Server-3: PulseAudio v: 15.0 running: no
Sound Server-4: PipeWire v: 0.3.42 running: yes
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Micro-Star MSI driver: r8169 v: kernel port: f000 bus-ID: 22:00.0
chip-ID: 10ec:8168 class-ID: 0200
IF: enp34s0 state: up speed: 100 Mbps duplex: full mac:
Local Storage: total: 480.3 GiB used: 1.78 GiB (0.4%)
ID-1: /dev/nvme0n1 vendor: Mushkin model: MKNSSDPE500GB-D8
size: 465.76 GiB speed: 31.6 Gb/s lanes: 4 type: SSD serial:
rev: 42A2S8MA temp: 30.9 C scheme: GPT
ID-2: /dev/sda type: USB vendor: Kingston model: DataTraveler 2.0
size: 14.54 GiB type: N/A serial: rev: PMAP scheme: GPT
ID-1: / size: 10 GiB used: 46.2 MiB (0.5%) fs: overlay source: ERR-102
Alert: No swap data was found.
Message: No sensor data found. Is lm-sensors configured?
Processes: 293 Uptime: 2m wakeups: 0 Memory: 15.61 GiB
used: 1.62 GiB (10.4%) Init: systemd v: 249 target:
Compilers: gcc: 11.1.0 Packages: pacman: 888 Shell: Bash v: 5.1.12
running-in: xfce4-terminal inxi: 3.3.10

Apparently your Ethernet connection is up and active.

Check you have an IP address, e.g.

ip a show enp34s0

and try pinging your router. If you have an IP address and can ping your router then it’s likely an issue with DNS.

I typed the command and this is the result. What does it mean
2: enp34s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP group default qlen 1000
link/ether 00:d8:61:c9:7e:da brd ff:ff:ff:ff:ff:ff
inet brd scope global dynamic noprefixroute enp34s0
valid_lft 3594sec preferred_lft 3594sec
inet6 fe80::8e92:2e6c:ca60:e2a6/64 scope link noprefixroute
valid_lft forever preferred_lft forever

It means you have an IP address which means your LAN is working. This in turn means, if you still cannot access sites on the Internet, that the issue is with your DNS resolver. Or, you have no Internet connection on your router. Or your ISP is blocking connections. Whichever it is, it’s not an issue with the EnOS installation.


Sorry im new to linux but is there a way for me to fix it

Maybe, but you’d have to work out what’s wrong first.

Can you

ping -c3


Also, what’s the output of

cat /etc/resolv.conf


Oh my god i fixed it. I changed my DNS settings on my router and now i can connect to internet

Thanks for the help. Couldnt have done it without you