No internet connection found to install

I have fallen in love with Endeavouros. But I want to install Kde or i3wm on my computer but sadly I can’t install it. Whenever I am going to install online version it’s saying " No internet connection found". I have wifi connection and lan connection also. Even if I choose mirror also ok. It’s just happening when I am going to install online version. I have tried some day but it’s alway same.

1 Like

Welcome to EndeavourOS! … you might want to just install XFCE using the offline installer, sort out the right driver(s) for your Wifi/LAN … then install KDE or i3wm after the fact. There is an article to help guide you on doing this - https://discovery.endeavouros.com/general-system-settings/how-to-install-desktop-environments-next-to-your-existing-ones/2021/03/

1 Like

working just fine here

Do you have the same hardware as the OP?

@tareqjhe1
Are you saying that you do have a working connection? Or not?

If not, can you use your phone’s USB tethering?

1 Like

@tareqjhe1 say he has I have wifi connection and lan connection
but " No internet connection found"

@tareqjhe1 is your system a prebuilt or did you put it together? Do you know what hardware specifically youre running as you may need to load a different NIC driver.

I tried all the way that i can. I tried phone lan wifi. But all are failed. But other distros are very ok.

I don’t know why it’s happening. I tried all the way.

Thank you so much. I can try this way. I hope this will be ok

Try disabling vpn and see if that is the issue. Since you u can not access the internet via any method this could be the common denominator.

I am sorry to say that I don’t use vpn. Although I am living in China currently. However, This is still same but I have installed other Desktop environment as mentioned in the first comment.

Everyone thank you so much for trying to help me.

This is crucial information, and should have been included in the original post.

Connections to various services and mirrors are blocked in China - there is nothing that anyone can do about that.

You can, however, switch to mirrors located inside the Great Firewall and then things will work as expected.

I don’t think this is a problem. I installed arch or other distros also I never face any problem. Even I saw china have so many mirrors for arch or other distros.

Some users have successfully installed by using vpn.

How does the installer check for a network connection? If it pings anything not allowed by the firewall that could be why.

@tareqjhe1 EOS installer may work differently than other Distros youve tried. One Distro installer is not equal to all of them.

I agree with @manuel I would see if a VPN helps you

GitHub is known to get blocked in china, and we still use it in the process.

1 Like

Agree with U. When I boot up, firefox worked well. But installer reported no net.

Online文件里面有个测试网络的链接,因为是个被墙的网址,一直联不上,导致联网失败。

要改一下那个文件:

nano /etc/calamares/modules/welcome_online.conf

https://duckduckgo.com 改成https://www.baidu.com

这样就可以了。。。

1 Like