No internet after reboot

Hello,

So before all of this I believe I ran some sort of command with pacman and that ended up changing my desktop background to say “Endeavor OS Atlantis” everything was still working at this time but then I restarted my pc and my internet wasn’t working. I checked to see if my ethernet adapter was showing up and it wasn’t. But my friend made me run a command and my Realtek Ethernet Adapter was showing up, just not in settings. I am honestly lost, the weird thing is that when I load up bpytop I still see some network activity. Here is my neofetch if it’s of any use and please keep in mind that this is my first proper experience with Linux and I am 110% a beginner.

Please let me know if you need any other information.

Thanks,
Jake

Welcome! :smile:

We need some more info to solve this, so could you show the output of terminal command

inxi -Faz | eos-sendlog

?

Making a note of what you do and what changes you make is 110% important for a 110% beginner.

What was that command?

2 Likes

That was my first thought. @jake who is your friend? And if they helped you get this far, why aren’t they still helping you? I would find out what they did, but with “I ran some sort of command,” I would start with find out what it was so we can backtrack from there.

You can check on the terminal and enter history and post the command here?

Also if you are 110% newbie, how come that you have a terminal with zsh?

Your friend is totally fiddling with your install and now it is not functional. Need more infos as said above :face_with_raised_eyebrow:

1 Like

I didn’t even know this. Awesome! I’ll definitely make use of this when helping, that’s very useful.

1 Like

We’re definitely here to help. But, to be honest - 110% beginner there may be better distros for you to start your Linux journey. We’re generally geared towards terminal centric folk who need a starting point to finish building their own system. You may have a vastly better Linux experience with Mint or Manjaro honestly. They will give you a much better “complete experience”, with a fully configured system in all regards. I’m not saying this to belittle, just that, if this is legit your absolute first Linux experience, you mayfind yourself in way over your head which is totally possible, it may leave a really poor impression of Linux overall for you at no fault of your own.

If you’re ambitious and aren’t afraid of learning - this is a great place to be.

1 Like

I agree, but start from scratch installation. Read the wiki and forum and ask questions. Having a friend punching in random commands and not explaining what’s going on is less than helpful. Eos should work out of the box unless there is really something with the hardware driver.

Yes, here.

The commend is failing because you don’t have internet. Run inxi -Faz only you will get a text output. Post the output here. Also, as many said above it would be great if you can track down what command your friend ran on the system. Just run the command in your terminal history will show you a list of commands you have run for the current session.

Thank you for bringing this up to to me, so I originally started with Manjaro on a Mac and it broke after a month, and then I had a friend using EndeavourOS and they were like you should use it, so that’s how I got here. I wouldnt mind changing distros but I need to figure out a way to transfer all of my projects etc without GitHub.

Did you try uninstalling r8168 package.

I have no clue which command broke it, but one of them did. The commands down at the bottom were my friends when he was trying to help me and those commands has zero response.

When it comes to Linux you need to find your own cup of coffee. A distro that works for one might not work for you. It would have been better if you have stuck with Manjaro because you’re familiar with it. Endeavour is different from Manjaro.

Enos tries to be close to vanilla Arch as much as possible so the customization level is minimal right out of the box. We tend to keep things minimal as possible.

Don’t know what you mean by this though. Do you have lots of projects that you want to change or something? You can use GitLab (better than GitHub). Or use something like mega.nz cloud service which offers 50Gb for free users.

I disagree here. Mint is one thing, but Manjaro is still a rolling-release with additional layers of complexity over EnOS.

You have a number of Docker commands in there. Docker will happily play with network settings, and depending on the compose file you’re using this could explain why your network broke.

Your network adapter is showing in inxi, which probably means it’s a routing issue.

Check ip route and make sure the default route is your router.

I don’t have internet on my computer, so how would I do that? And I have had no issues with GitHub basically I just have projects that I don’t wanna lose.

What does this show

pacman -Qi r8168

He was using it before his Mac broke so wouldn’t have been better sticking with what you know.

Also, one more thing I can see your NetworkManager in the background of your images. From what I see it only seems to have bridges or am I mistaken.

It normally looks likes this.
image

But I only see the Bridge part. If possible post an image of your NetworkManager.

Yes, my Ethernet adapter isn’t showing up in settings only my bridges.

What do you get when you run ifconfig or nmcli? If you can show the output would be great.

Also try what @ricklinux is saying above.