No GUI after kernel update/ can't get into terminal either

I’ve just updated my system and I believe it messed up the nvidia drivers (again!), as I cannot access the GUI (I believe it was using lightdm if I’m not wrong)

Desktop Environment: XFCE

I have tried changing the grub boot so that it boots to quiet as the other time I was able this way to login into console to update the drivers, but this doesn’t work. Maybe I’m missing another option?

I tried running ctrl+alt+f2 or any other combination of ctrl+alt+fn+fX but it didn’t work, I can’t get into the console, therefore I’m not able to run anything.

I’ve tried booting into both LTS and non-LTS (+ the compatiblity mode but I’ve forgotten how was that called).

What other solutions do I have?

Thank you

FYI: I believe it fails on loading some kernel modules too, sometimes it stays stuck on that for like 10-30s, if I boot with quiet then that just fails and that’s it.

You can boot with the installer ISO and use arch-chroot to get into your installed system. Here are some instructions:

Then you can run practically any terminal commands to fix the system and/or show some logs for us in the forum.

Some useful logs can be sent with these commands:

inxi -Fza | eos-sendlog
cat /var/log/Xorg.0.log | eos-sendlog

Then show the returned URLs here.