No GPT During Installation, No Boot Options

I got another laptop and trying to install from the same flash disk I just installed a few days ago.

During disk partitioning I have only MBR, and can not change it! Though as I procede the installer gives a message I should have a GPT!

I just replaced the added an SSD, and the HDD went in the place of the DVD drive (hoping to use it for storage.

Here is my inxi -Fxz

[liveuser@eos-2022.06.23 ~]$ inxi -Fxz
  Kernel: 5.18.5-arch1-1 arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
    Desktop: Xfce v: 4.16.0 Distro: EndeavourOS base: Arch Linux
  Type: Laptop System: FUJITSU product: LIFEBOOK AH531 v: N/A
    serial: <superuser required>
  Mobo: FUJITSU model: FJNBB0F serial: <superuser required>
    UEFI-[Legacy]: FUJITSU // Phoenix v: 1.32 date: 10/01/2018
  ID-1: BAT1 charge: 12.6 Wh (74.6%) condition: 16.9/48.8 Wh (34.6%)
    volts: 12.3 min: 11.1 model: SIMPLO AS10B7E status: charging
  Info: dual core model: Intel Core i5-2450M bits: 64 type: MT MCP
    arch: Sandy Bridge rev: 7 cache: L1: 128 KiB L2: 512 KiB L3: 3 MiB
  Speed (MHz): avg: 2942 high: 3084 min/max: 800/3100 cores: 1: 2894
    2: 2894 3: 2899 4: 3084 bogomips: 19967
  Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Device-1: Intel 2nd Generation Core Processor Family Integrated Graphics
    vendor: Fujitsu driver: i915 v: kernel arch: Gen6 bus-ID: 00:02.0
  Device-2: Chicony Fujitsu Integrated Camera type: USB driver: uvcvideo
    bus-ID: 1-1.3:3
  Display: server: X.Org v: 21.1.3 driver: X: loaded: intel
    unloaded: modesetting gpu: i915 resolution: 1366x768~60Hz
  OpenGL: renderer: Mesa Intel HD Graphics 3000 (SNB GT2)
    v: 3.3 Mesa 22.1.2 direct render: Yes
  Device-1: Intel 6 Series/C200 Series Family High Definition Audio
    vendor: Fujitsu driver: snd_hda_intel v: kernel bus-ID: 00:1b.0
  Sound Server-1: ALSA v: k5.18.5-arch1-1 running: yes
  Sound Server-2: PulseAudio v: 16.1 running: no
  Sound Server-3: PipeWire v: 0.3.52 running: no
  Device-1: Intel Centrino Wireless-N 1030 [Rainbow Peak] driver: iwlwifi
    v: kernel bus-ID: 01:00.0
  IF: wlan0 state: up mac: <filter>
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Fujitsu driver: r8169 v: kernel port: 2000 bus-ID: 07:00.0
  IF: enp7s0 state: down mac: <filter>
  Device-1: Intel Centrino Advanced-N 6230 Bluetooth adapter type: USB
    driver: btusb v: 0.8 bus-ID: 2-1.4:5
  Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
  Local Storage: total: 727.94 GiB used: 0 KiB (0.0%)
  ID-1: /dev/sda vendor: Samsung model: SSD 870 EVO 250GB size: 232.89 GiB
  ID-2: /dev/sdb vendor: Seagate model: ST9500325AS size: 465.76 GiB
  ID-3: /dev/sdc type: USB vendor: Generic model: Flash Disk size: 29.3 GiB
  ID-1: / size: 10 GiB used: 1.95 GiB (19.5%) fs: overlay source: ERR-102
  Alert: No swap data was found.
  System Temperatures: cpu: 82.0 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 194 Uptime: 1h 47m Memory: 3.75 GiB used: 3.5 GiB (93.4%)
  Init: systemd Compilers: gcc: 12.1.0 Packages: 902 Shell: Bash v: 5.1.16
  inxi: 3.3.18

and my lsblk

[liveuser@eos-2022.06.23 ~]$ lsblk
loop0    7:0    0   1.6G  1 loop /run/archiso/airootfs
sda      8:0    0 232.9G  0 disk 
└─sda1   8:1    0 232.9G  0 part 
sdb      8:16   0 465.8G  0 disk 
└─sdb1   8:17   0 465.8G  0 part 
sdc      8:32   1  29.3G  0 disk 
├─sdc1   8:33   1   1.7G  0 part /run/archiso/bootmnt
└─sdc2   8:34   1   102M  0 part 
sdd      8:48   1     0B  0 disk 

My previous installation went fine, with the correct defaults (I just followed defaults).

The SSD was placed in the same slot as the HDD was and the HDD is now in place of the DVD!

I do not know what is wrong this time! Is it because of having a HDD next to the SSD?
Is it because of the Grub issue?
Currently downloading the EndeavourOS_Artemis_neo_22_8.iso

I think that machine is too old for UEFI? I think you booted in BIOS mode but your disk is initialized as GPT. Or maybe one disk is GPT and the other is MBR. We need more info.

It’s not “the” grub issue I know that much. Can you open up a terminal and give us the results of this command?

sudo parted /dev/sda print
sudo parted /dev/sdb print

Surprisingly I could just reboot normally after doing some Grub commands… install, update… etc… as shown in the pinned post about the grub issue!

Well, this machine I believe is like 4 years old, while I was running smoothly on another one 10 years old!

May be this is related to the Grub issue?!
I do not know.

UPDATE: Rebooting again, back to the situation that made me make the OP. No boot options (maybe something like network boot only, only one single item!)

Are you booting the ISO in uefi mode?

[liveuser@eos-2022.06.23 ~]$ sudo parted /dev/sda print
Model: ATA Samsung SSD 870 (scsi)
Disk /dev/sda: 250GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start   End    Size   Type     File system  Flags
 1      1049kB  250GB  250GB  primary  ext4         boot

[liveuser@eos-2022.06.23 ~]$ sudo parted /dev/sdb print
Model: ATA ST9500325AS (scsi)
Disk /dev/sdb: 500GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start   End    Size   Type     File system  Flags
 1      1049kB  500GB  500GB  primary  btrfs

[liveuser@eos-2022.06.23 ~]$ 

Sorry! I can’t tell.
I just insert the flash disk and press the power button, it automatically boots to the live session!

Figure out how to bring up the bios boot menu or go into the bios and disable legacy

1 Like

I don’t think he’s got a choice, that proc is 10 years old. Even if the system had got UEFI I bet it’s on the buggy side.

It is theoretically possible but I have been using UEFI exclusively for a lot more than 10 years.

Disabled legacy. Couldn’t even boot the flash disk!

This laptop had Windows 10 installed and running!

[liveuser@eos-2022.06.23 ~]$  sudo dmidecode | grep -C 3 -i date
BIOS Information
	Vendor: FUJITSU // Phoenix Technologies Ltd.
	Version: 1.32
	Release Date: 10/01/2018
	Address: 0xE0000
	Runtime Size: 128 kB
	ROM Size: 2560 kB
Portable Battery
	Location: Internal Battery
	Manufacturer: FUJITSU
	Manufacture Date:  
	Serial Number: 1032
	Name: CP477891-03
	Chemistry: Lithium Ion
[liveuser@eos-2022.06.23 ~]$ 

My other laptop is 10 years old and everything is perfect on it!

So? I run Windows 10 on plenty of BIOS machines. :slight_smile:

If you’re trying to boot to UEFI, both of those disks are formatted in msdos (MBR or BIOS mode) so they won’t work as is. They’d need to be reinitialized as GPT disks, which will wipe them.

while installing I do not have this option. I have only MBR and can not change it.

It’s showing you MBR because that’s how the disks are set up now, it’s just an indicator. You should be able to open up gparted and change it, but I think you have to reboot afterwards.

These disks are blank and/or disposable right? Nothing on them you want?

No… not t all!

Then go forth and reinitalize them as GPT disks good sir/maam/internet-inhabitant :grinning:

Pssst…it is the boot entry that says partition 2…boot that off the stick. :melting_face:

Sorry… couldn’t find GPT option in Gparted! Where or how can I do it!
Why it is not done automatically during installation as before?!

how is your bios … calamares hates when you do legacy or any csm. didnt read fully :slight_smile:

its possible if bios is legacy , calamares makes mbr, and install in efi a like, end up unbootable

check ani efi setting legacy or non legecay…

1 Like

I went to BIOS, disabled legacy… then I couldn’t even boot the flash disk!