No gear icon to choose wm after installing openbox or bspwm

installed openbox and bspwm after standard XFCE installation.
Followed this instructions from here:



all went ok. But on rebooting i have no other option. I have no gear to choose Between

I can only start XFCE. Any hint will be much appreciated.

Did you use the same user or different users?

Using the same use seems to mess things up. Because most CEs use XFCE as their base. So, you would see XFCE as the desktop environment. Windows managers are not DE’s,

Why would you use GDM wit XFCE? Beats me. XFCE normally uses lightdm. No? - EnOS normally uses lightdm-slick-greeter, not lightdm-gtk-greeter (the standard XFCE greeter), afaik.

So in your case, if you’re using gdm and gdm-greeter and no “gear” is shown, some dependencies might be missing, me thinks.


I mean, no gear to choose no matter the login. My wrong assumption on login, sorry

But I should be offered with one I want to login into. There is no option nor icon to choose as in my other laptop with arcolinux

Perhaps, you could dig into this, then:

Trying to make things clearer:
You have to use a display-manager (you said you use GDM).

That display-manager uses a so-called greeter (the login screen, with or without any gear to choose different WM/DE sessions installed).

I think, GDM greeter (not using it here) may only show a GEAR after entering the username (before entering a password)…

Again quoting what I said,


DE = Desktop Environment.
Ex: Gnome, KDR, XFCE, … etc

Tilling or none tiling windows managers are not complete desktop environments. If you have one too many installed using the same user account it might cause issues.

It seems you have installed the complete XFCE first then tried to install a WM over the XFCE. And you have GDM as your display manager which is failing to identify your WM over XFCE.

Installing a windows manager-based environment is a mix-match of parts from a desktop environment and a few other utilities. If you have installed a base system without any graphical interface and used the terminal to install one of the mentioned WM environments you would have been able to use that.

And to install another it’s best advised to create another user account and install your next WM environment onto that account. Because installing too many WM’s to one account messes things up.

You won’t see another DE. GDM doesn’t see another desktop environment because both windows managers use XFCE as their base. You must have used Acro’s installer. If you want a WM-based system you could have installed one of the community editions or one of the online editions from the Endeavour installer.

It has been a while since I used Gnome (GDM) but it seems that you have to type in and accept a user name, then the gear appears in the lower left of the screen.



Before I removed my XFCE session and was splitting my time between XFCE and Openbox. I switched between them via lightDM, not by clicking a gear, but there was a little mouse logo next to my login name which indicated I was going to login to the XFCE session. I could click that mouse and it would also provide me the option for Obenbox. I could switch between them pretty easily. I am not sure what you are seeing when you don’t have a gear icon

No thats not how it should be.

Window managers should show up as dedicated options in the selection menu.


Being precise, the window managers EndeavourOS currently offers should show up in sessions list.

1 Like


Could you share the output of this command?

ls /usr/share/xsessions/
1 Like

I am a complete moron. The step I missed is to install bspwm and then the bspwm themes from endeavourOs :innocent:
Same for any DE or WM

1 Like

Sounds like you got it working, glad to hear. Enjoy your new WMs


We all make mistakes when we start :innocent: