No external monitors detected

Hi, I have this setup: Laptop which has only one hdmi output, in that hdmi output, I have connected external monitor and also I have second external monitor connected through usb 3. On windows, all monitors are working as intended, yet on Endevaour OS, only main laptop screen is working, those other two external monitors are not getting any signal. I dont mind if usb 3 monitor is not working since it is a little wierd adapter setup, but hdmi should work no problem. I am arch newbie so I dont know where the problem is. Xrandr is giving me this:

Screen 0: minimum 16 x 16, current 1920 x 1080, maximum 32767 x 32767
XWAYLAND0 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 340mm x 190mm
   1920x1080    143.88*+
   1440x1080    143.90  
   1400x1050    143.89  
   1280x1024    143.92  
   1280x960     144.00  
   1152x864     143.92  
   1024x768     143.87  
   800x600      143.83  
   640x480      143.85  
   320x240      142.05  
   1680x1050    143.97  
   1440x900     143.86  
   1280x800     143.84  
   720x480      143.85  
   640x400      143.37  
   320x200      141.40  
   1600x900     143.93  
   1368x768     143.77  
   1280x720     143.85  
   1024x576     143.91  
   864x486      143.63  
   720x400      143.88  
   640x350      143.57  

So system dont even see other monitors as disconnected. Please help :slight_smile:

Welcome to the forum!

What graphics card and drivers are you using ? Here is more info on how to post your system info:

For starters what is the output of:

inxi -G
1 Like

Graphics:
Device-1: Intel UHD Graphics 630 driver: i915 v: kernel
Device-2: NVIDIA GP106M [GeForce GTX 1060 Mobile] driver: nvidia v: 465.31
Device-3: DisplayLink USB3.0 to DVI Adapter type: USB driver: N/A
Device-4: Quanta HD Webcam type: USB driver: uvcvideo
Display: wayland server: X.org 1.20.11 driver: loaded: intel,nvidia
unloaded: fbdev,modesetting,vesa resolution: <missing: xdpyinfo>
Message: Unable to show advanced data. Required tool glxinfo missing.

Here two potential problems:

  • wayland and nvidia do not work together. Can you login in the xorg session? Which DE are you using gnome? Can easily be selected at login…
  • you may need to install nvidia optimus via yay, so that you can switch to hybrid mode or only dedicated graphics card

Edit: here some info on nvidia and optimus:

  • Yes, Gnome. If I switch to xorg Gnome, Hdmi monitor works, usb3 monitor not (not that crucial). What is the difference between wayland and xorg then?
  • So optimus will not help me with wayland version right?

Hi there, I got the same problem. And I installed optimus-manager via yay, I tried switching between hybrid and nvidia, but no luck :frowning:

No it won’t. Xorg is the “old” display manager used by linux and all programs, wayland is the future display manager, for example fedora uses it as default (except if you run nvidia cards). I know that wayland better works for multiple scaling on different screens, which is necessary for 4k laptop mixed with conventional 1080 dpi monitor. So it is a bummer.

Unfortunately it does not support well nvidia proprietary drivers.

Edit: glad that your problem is solved.

It depends on your hardware and driver support. Can’t really compare all hybrid card problems with each other…

Edits: Looking at your post, perhaps try switching to nvidia only?

Then check whether the new nvidia driver 465 is supported by your card or whether you need the older legacy 360 driver. You can check on nvidia webpage, select linux as OS.

According to your xrandr post it seems to recognize both monitors.

I agree set it up with use xorg and install nvidia-dkms and set up all the nvidia enhancements plus optimus-manager. Get that working first and then set up the external monitors.

1 Like

Please search the forum for your problem first, before posting about it, and don’t cross-post. Once is enough, really.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.