No EndeavourOS option in GRUB after update

Today I did a full system upgrade (pacman -Syu). After rebooting, my GRUB only shows Windows and UEFI BIOS menu but no entry for EndeavourOS.

How do I fix this issue? I would usually do something like this from within Linux but now I am just locked out.

Thanks for the help!

I’ve tried using boot repair disk and super grub2 disk to fix grub issues in the past.
These are iso’s you can burn onto a USB disk and boot to a live environment to fix the grub.


Use a USB with a Linux live installer environment, chroot into the installed system and make sure the kernel installed and the initramfs was generated correctly, and then regenerate the GRUB menu.


Also might be worth to have a look here:

For chrooting:


Thanks for the quick replies! I need to find a USB stick now and I‘ll have to skip planned work tomorrow for this. Really curious what happened

You probably have more than 1 EFI would be my guess.

So efibootmgr says efi is not supported. That‘s also what grub-install fails with. But I have two efi partitions for both Linux and Windows so I assume I used it as an EFI install. What could be the cause of this?

Oh, do you mean more than one efi partition? Because that is indeed the case. What now?

Okay, efiboormgr now finds Both Linux and EndeavourOS. os-prober still only finds Windows, though and grub-mkconfig only adds entries for Windows and UEFI setup, as it did before

/boot is basically empty, there is no vmlinuz. So it seems the kernel did not get installed properly? I will try yay -Sy linux. Is that correct?

If you use the linux kernel, then yes. However, given the state of your system you should update at the same time with:

sudo pacman -Syu linux
1 Like

Omg I fixed it. It seems I rebooted while the kernel was updating or something like that. Thanks for all the help! Now I need to destress


Mutltiple EFI partitions aren’t disastrous, but do lend to much confusion and should probably be avoided.

I don’t think the issue was related to having multiple efi partitions at all. I run multiple efi partitions on dual boot and never had an issue. Looks like it was an incomplete update.


I found somewhere the opposite claim: if you‘d use Windows‘s EFI for Linux then that would break it. But I can‘t find the source and apparently either way is fine

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.