No digital audio output from SPDIF

Hello guys, and thank you a lot for being an awesome community.

I have recently installed EOS on a Minisforum HX90.
I could not verify through the minisforum forum page if it actually support digital output (SPDIF), but luckily EOS identified the SPDIF output.

The only problem is that I am not getting any output.

To put it in context, I also an old iMac (from 2011) which has combined stereo/SPDIF output from 3.5mm jack.
On that machine, which runs Manjaro, I can connect my soundbar using mini-toslink adapter, and everything works fine.

Sadly on the HX90 I get no digital output from the 3.5mm jack when I plug the mini-toslink adapter, yet the system can identify it.
Below I am showing the output from inxi -A (might update the post with more information later).

inxi -ASxxxz

  Device-1: AMD Renoir Radeon High Definition Audio driver: snd_hda_intel
  Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor driver: N/A
  Device-3: AMD Family 17h/19h HD Audio driver: snd_hda_intel
  Device-4: C-Media Audio Adapter (Unitek Y-247A) type: USB
    driver: cmedia_hs100b,snd-usb-audio,usbhid
  Sound API: ALSA v: k6.0.9-arch1-1 running: yes
  Sound Server-1: PipeWire v: 0.3.60 running: yes

I am not sure if I require an adapter, or it is just a driver/kernel issue.

It would great if somebody could help.

Thanks a lot in advance

Your “AMD ACP/ACP3X/ACP6x Audio Coprocessor driver” doesn’t appear to be present. lists that device as “detected” for Arch while Manjaro has a status of “works”. This page lists which driver was installed and working for Manjaro.

Device: ACP/ACP3X/ACP6x
Driver: snd_pci_ac_p3x

1 Like

Thanks a @adjagu . So basically this means it is not sure when it will be fixed?
Or I could install packages that Manjaro uses?

To tell you the truth, I am a bit confused on why it would work with Manjaro and not with Arch, since Manjaro is based on Arch…
Sorry for the off-topic question though.

I am not sure @salvocos. From the information you posted I was able to find the information I shared with you, but as for what to do with it I am unsure. Hopefully someone more knowledgeable will be able to help you resolve this.

Yes, I guess I will need to wait or do some extra search.

Looks like it works on Endeavour with snd_usb_audio driver :

According to your inxi command, the driver is loaded, maybe something’s wrong in the mixer settings.

Hello @vazicebon and thank you for checking.
I am sorry if I did not write it in the main post, but basically I can get stereo output (e.g. heardphones) when I select Unitek Y-247A.
The problem is related to the Digital Output (SPDIF).
When I selected SPDIF I would still get stereo output, and I get not sound when I connect my soundbar (which requires a digital source) using the mini-toslink adapter.
Regarding the mixer, I have not touched anything, I am using a fresh installation.

TLDR: normal stereo output works, SPDIF is not working.

Will try later if using an LTS kernel would help.

You could check in the mixer if you can see and/or select the digital output.

I use a HDMI TV for my monitor, and the TV has a SPDIF out fiber connector.
I just run a SPDIF cable over to the Yamaha A / V receiver and turn down the volume on the TV.
The A / V receiver has a 5.2 setup and leaving just a little audio coming out the TV actually adds a little depth to the music.

This is how I get decent audio from my ARM devices as most ARM devices are not equipped with SPDIF connectors.

Not familiar with SPDIF out connectors on most computer monitors, but if available it could be an alternative.


@vazicebon thank you for your comment. The Unitek Y-247A drivers seems loaded and working.

I am attaching an extended output of inxi if can bee of any help.

âžś sudo inxi -Axxx
  Device-1: AMD Renoir Radeon High Definition Audio driver: snd_hda_intel
    v: kernel bus-ID: 1-1:2 pcie: speed: 8 GT/s chip-ID: 0d8c:0014
    class-ID: 0300 lanes: 16 bus-ID: 04:00.1 chip-ID: 1002:1637 class-ID: 0403
  Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor driver: N/A pcie:
    speed: 8 GT/s lanes: 16 bus-ID: 04:00.5 chip-ID: 1022:15e2 class-ID: 0480
  Device-3: AMD Family 17h/19h HD Audio vendor: Realtek
    driver: snd_hda_intel v: kernel pcie: speed: 8 GT/s lanes: 16
    bus-ID: 04:00.6 chip-ID: 1022:15e3 class-ID: 0403
  Device-4: C-Media Audio Adapter (Unitek Y-247A) type: USB
    driver: cmedia_hs100b,snd-usb-audio,usbhid
  Sound API: ALSA v: k6.0.11-arch1-1 running: yes
  Sound Server-1: PulseAudio v: 16.1 running: no
  Sound Server-2: PipeWire v: 0.3.61 running: yes

Regarding the mixer, I assume you mean something like pavucontrol.
When I open it and select digital stereo (or surround 5.1) output it still does not work.

Thank @pudge for your comment. Sadly I sue a Monitor and do not have optical fiber connector.
Probably, if I cannot fix this problem I might need a digital extractor or sound card.

Thank you @ricklinux I had already tried this before, and did not solve the problem.

Like @adjagu previously suggested, I also think the problem might be related to the AMD ACP/ACP3X/ACP6x Audio Coprocessor drive not being loaded/installed.
If the next LTS kernel (6.1?) does not solve the problem, I am considering buying a cheap USB card with optical output. StarTech 7.1 seem to be an option for now.

Maybe check this out.

You said you have a mac and a hx something. So it’s 2 device. Start by making sure the spdif do work on both. Just boot a live xubuntu , open terminal and : alsamixer , turn spdif to on / unmute. and play test signal or just a wave file. no 5.1 other strange file. if optical is supported, then in arch it will too. But getting it may be an issues sometimes.

Adding the kernel parameters did not solve :frowning: