No boot files installed in /boot/efi?

I am installing EOS offline edition on a 64-bit Intel machine, on the same system disk that currently contains Windows 11. Here are the actions listed for the install:

 Format 51200MiB partition /dev/nvme0n1p5 with filesystem ext4
   Set filesystem label EOS-root to partition /dev/nvme0n1p5
   Format 20480MiB partition /dev/nvme0n1p6 with filesystem ext4
   Set filesystem label EOS-var to partition /dev/nvme0n1p6
   Format 15360MiB partition /dev/nvme0n1p7 with filesystem ext4
   Set filesystem label EOS-swap to partition /dev/nvme0n1p7
   Format 102400MiB partition /dev/nvme0n1p8 with filesystem ext4
   Set filesystem label EOS-home to partition /dev/nvme0n1p8
   Set up FAT32 partition /dev/nvme0n1p2 with mount point /boot/efi
   Install EndeavourOS on ext4 system partition /dev/nvme0n1p5
   Set up ext4 partition /dev/nvme0n1p6 with mount point /var
   Set up ext4 partition /dev/nvme0n1p8 with mount point /home
   Install boot loader on /

Everything appears to install fine, but no files apparently get installed into /boot/efi, so I end up rebooting into Windows always.

Am I missing something in the installation setup?
Is the install log saved anywhere, so that I can examine it?

For better readability, please format the pasted text by highlighting it and clicking on the </> button.

Also, look into your firmware/uefi settings to see if you need to change the boot priority to EnOS.

Another thing to check, from the live session, would be the output of the
efibootmgr -v

I have looked at the boot priority. It is set to check the appropriate disk before going to the Windows boot loader, but attempting to boot from there seems to do no good, as it is finding no boot files. When I look at the EFI partition, there is no directory for EndeavorOS.

I try running efibootmgr from the live session, and it returns the error message: “EFI variables are not supported on this system”.

This looks quite off to me.
Could you post

sudo parted -l

?

Here are the boot choices listed by my Gibabyte UEFI interface.
P3: ASUS BW-16D1HT (my empty Blu Ray drive)
Samsung SSD 970 PRO 1 TB (my system disk)
Windows Boot Manager (-- same system disk)

Are you trying to use manual partitions and setting this up yourself?

Running parted -l in the live session generates no output. I’m not familiar with how the live session works. Do I need to mount my partitions somewhere?

Go into BIOS and disable CSM/Legacy boot mode.

Boot up your EnOS installer in UEFI mode and try again:

efibootmgr -v

1 Like

Yes. I am running the “manual partitioning” option. The last part of that form asks for a boot location, which is where the “install boot loader on /” comes from. What I would expect is an option to install it in “/boot/efi”.

Please post the output that @pebcak has asked for.

No.

just:

sudo parted -l

or

sudo fdisk -l

Sorry. Got it right this time…

[liveuser@eos-2022.04.08 ~]$ sudo parted -l
Model: ATA Samsung SSD 860 (scsi)
Disk /dev/sda: 2000GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags:

Number Start End Size File system Name Flags
1 17.4kB 16.8MB 16.8MB Microsoft reserved partition msftres
2 16.8MB 859GB 859GB ntfs Basic data partition msftdata
3 859GB 1396GB 537GB ntfs Basic data partition msftdata

Model: SanDisk Cruzer (scsi)
Disk /dev/sdb: 61.6GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags:

Number Start End Size Type File system Flags
1 1049kB 61.6GB 61.6GB primary fat32 boot, lba

Model: Samsung SSD 970 PRO 1TB (nvme)
Disk /dev/nvme0n1: 1024GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags:

Number Start End Size File system Name Flags
1 1049kB 17.8MB 16.8MB Microsoft reserved partition msftres
2 17.8MB 542MB 524MB fat32 EFI system partition boot, esp
3 542MB 376GB 376GB ntfs Basic data partition msftdata
5 376GB 430GB 53.7GB ext4
6 430GB 452GB 21.5GB ext4
7 452GB 468GB 16.1GB linux-swap(v1) swap
8 468GB 575GB 107GB ext4
4 1013GB 1024GB 10.9GB ntfs Microsoft recovery partition diagPreformatted text

Formatted for you :wink:

[liveuser@eos-2022.04.08 ~]$ sudo parted -l
Model: ATA Samsung SSD 860 (scsi)
Disk /dev/sda: 2000GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags:

Number Start End Size File system Name Flags
1 17.4kB 16.8MB 16.8MB Microsoft reserved partition msftres
2 16.8MB 859GB 859GB ntfs Basic data partition msftdata
3 859GB 1396GB 537GB ntfs Basic data partition msftdata

Model: SanDisk Cruzer (scsi)
Disk /dev/sdb: 61.6GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags:

Number Start End Size Type File system Flags
1 1049kB 61.6GB 61.6GB primary fat32 boot, lba

Model: Samsung SSD 970 PRO 1TB (nvme)
Disk /dev/nvme0n1: 1024GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags:

Number Start End Size File system Name Flags
1 1049kB 17.8MB 16.8MB Microsoft reserved partition msftres
2 17.8MB 542MB 524MB fat32 EFI system partition boot, esp
3 542MB 376GB 376GB ntfs Basic data partition msftdata
5 376GB 430GB 53.7GB ext4
6 430GB 452GB 21.5GB ext4
7 452GB 468GB 16.1GB linux-swap(v1) swap
8 468GB 575GB 107GB ext4
4 1013GB 1024GB 10.9GB ntfs Microsoft recovery partition diag
1 Like

This would be my suggestion for a basic manual installation:

  1. EFI System Partition: already present on your disk (/dev/nvme0n1p2).
    This should be mounted at /boot/efi in the installer with boot flag. OBS! Don’t format this partition!!
    This is where your bootloader will be installed.
  2. One EXT4 partition to be mounted at / ( Size depends on you use case)
  3. One EXT4 partition to be mounted at /home
  4. swap (it depends). It is a must if you want to hibernate.

You could as well include the home directory under / if you prefer. It all depends.

Okay. Thanks. With the exception of the extra /var partition, this looks like what I did. Shouldn’t there be some files placed into /boot/efi? When I look at /boot/efi from Windows, I see nothing added by Linux under the EFI subdirectory.

There will be when mounted properly at /boot/efi with boot flag.

Just don’t format this partition since it also harbors your Windows boot files.

Okay. Good. That’s what I’m expecting but not getting.
NOTE: I did mount the EFI partition to /boot/efi.

In BIOS, disable Legacy/CSM boot mode so that your EnOS installer will boot up in UEFI mode automatically.

Reinstall the system with the instruction given above.

And again, make sure not to format /dev/nvme0n1p2 !!

1 Like

I found the CSM setting and turned it off. That did it!
The Calamares installer adapted to the change as well.
It no longer asked for a boot location.

Thank you all so much!!!

1 Like

Glad you got it working!

Please pick the post that pointed you to the solution and mark it as such by clicking … and checking the box. This will make the topic searchable as solved and other users with similar issue will find the solution easily. Thanks!