No bass with 7.1 and ASUS STRIX

Hey there,

i’m new to EndeavourOS and in my search for getting away from Windows i tried many distros and in my opinion EndeavourOS is by far one of the best i tried. Great job.

But i got a little issue which don’t want to get solved.

I have a 7.1 Surroundsound and an ASUS STRIX SOAR. In PulseAudio i set the Profile to “Analog Surround 7.1-Output + Analog Stereo Input”. Each Channel is working fine, but the Subwoofer won’t emit any tone.

I tried adding the entries described here:

But it didn’t solve the problem.

Can anybody help me?

Thanks :-).

1 Like

Hi @ejtschpi, which bios do you use on which motherboard ?
Are you on XFCE4 or on another DE ?

Could you give here the result from ?


hello @ejtschpi
I don’t think upmixing/downmixing is what you should be looking at. It’s in the configuration somewhere. Have you checked the audio settings for output? Depending on the desktop you can click on the volume control and get to it or another way. What does alsamixer show? You may have to run some commands and look at the sinks to see if it’s configured properly.

Check that you are on the proper output. Also check:


pactl list

Look at Alsa Troubeshooting and PulseAudio

If you are using the ‘standard’ Xfce Desktop Environment, try the following and be VERY CAREFUL:

Open Terminal and type su

Enter your password and then type thunar

Open File System, then open etc, then open pulse

Within pulse you will see four files. Open the second one which is labeled daemon.conf
(It is preferable to open it with Leafpad.)

Slowly scroll down until you see the lines:
; enable-lfe-remixing = no
; lfe-crossover-freq = 0

Change the values to yes and 80 [or whatever other frequency you desire; 80 is a good general value] Remove the ; in front of those two lines.

Save the changes you made.

Close everything out and then reboot.

Now see if your subwoofer functions as it should.

Please let me know whether or not this has been helpful to you.




Not sure if you’ve made any progress but you could also use the command line.


Here is some information on pacmd and also pactl which is at the bottom of the page. There is also other information. It’s a good resource.


this is the output from speaker-test:

speaker-test 1.2.2

Playback device is default
Stream parameters are 48000Hz, S16_LE, 1 channels
Using 16 octaves of pink noise
Playback open error: -2,No such file or directory

Now i’m using KDE but i had the same issue with XFCE, which i used previously.
BIOS Version is A.30 and my motherboard is a MSI X570 GAMING PLUS

Something is wrong with

Playback open error: -2,No such file or directory

Could you give me the result of your motherboard Bios on this format below, I have a MSI also this is the result I have with :

sudo dmidecode | less
BIOS Information
        Vendor: American Megatrends Inc.
        Version: H.G0
System Information
        Manufacturer: Micro-Star International Co., Ltd.
        Product Name: MS-7A34

So, this is what sudo dmidecode | less returns:

BIOS Information
        Vendor: American Megatrends Inc.
        Version: A.30
System Information
        Manufacturer: Micro-Star International Co., Ltd.
        Product Name: MS-7C37
        Version: 2.0

HI, i tried it but unfortunately it didn’t solve the problem. The subwoofer still doesn’t want to give a sound a way.

So I do believe your Bios driver is this one :

Version 7C37vA3
Release Date 2019-08-31

The latest one is a Beta so don’t update your Bios with this one but with :

Version 7C37vA6
Release Date 2019-11-08

Do this first, then we will see with 7.1, it seems you have a multi channels sound card but Pusleaudio only uses 2 channels from the setup…

For this you open your /etc/pulse/daemon.conf file then uncomment semicolon and put 8 (which is 7.1) in spite of 2 like this :

default-sample-channels = 8

A reboot could be helpfull…

Then give me the result from :

aplay -L

Hey guys,

i’m sorry. I’m such a dummy… The solution from lhb1142 did the trick, but i just forgot to delete the semicolon facepalm

Anyways big thanks to you all for helping me. Now i can enjoy listening to music again :slight_smile:

1 Like

Great you got it work. Don’t forget to click solution to @lhb1142 :rocket: