No Audio on Tiger Lake Chromebook


i just recently purchased a Lenovo Ideapad Flex 5i chromebook. The device is Tiger Lake based and has the Intel Pentium Gold 7505 processor.
I was able to flash an UEFI-firmware with the help of Afterwards i installed the laltest EndeavourOS from USB pen drive (using the online installer). I have choosen the Gnome Desktop (currently installed in the Version 43). Furthermore, the installer has installed the latest linux kernel 6.0.11-arch1-1.
Almost everything worked out of the box, except audio. I already read that the latest Tiger Lake chromebooks might not be supported by the current Kernel in regards to audio. Nevertheless, i wanted to give it a try.

Status Quo
There is currently no audio only a “dummy output” device. aplay -l returns this

aplay -l
aplay: device_list:274: keine Soundkarten gefunden ...

It’s german, but it meas no sound card found :-).

I have tried to fiddle around with the usual things like loading the intel sound driver kernel module with

modprobe snd_hda_intel

But no luck. I tried the solutions from the arch wiki here, but that also didn’t work. Each time i reboot i get the “dummy output” device.

I’m not sure, where i could start searching. dmesg does not return anything interesting. Does anyone have any information about the current status of audio on tiger lake chromebooks?

Audio is not that important for me, as i intend to use this laptop as a browsing machine / type writer. Still i’m interested in getting it t work.

Try installing linux-mainline from AUR.

I’ll try it.
Sorry if that’s a beginner question, but installing linux-mainline from AUR means effectively, that I’m going to compile a linux kernel on my machine?

Yes. If you want to skip compilation you can add miffe repo or Chaotic AUR and just run

sudo pacman -S linux-mainline

Pick mainline kernel on boot menu.

Thanks for the hint. Unfortunately, the repos somehow didn’t work. I tried to add them, but something failed with the GPG-keys. As i didn’t wanted to fiddle around too much i just went for the YAY/AUR option. My laptop is now “baking” the kernel since two hours. I guess, it’s going to run over the night. Guess I’ll have to find a quite place for it to run. Will report back when it’s done.

still compiling. Oh boy, that’s going to take some time. Currently at this step (see screenshot). Not sure where the virtual progressbar would be?


Small update. I installed the mainline kernel and rebooted, but still no audio or only “dummy output” as audio.
Looking on this table here i don’t think there is a good chance to get audio working. All models from 2019 have at least one issue with audio.

There goes another update. Just tried some different combinations.

  • A headset on the jack plug does not work
  • An USB sound card with a headset works!
  • A bluetooth headset works!