No audio on a fresh install

when i plug in my headset the audio works just fine but my laptops internal speakers dont work.
Audio: Device-1: Intel Broadwell-U Audio vendor: Dell driver: snd_hda_intel v: kernel bus-ID: 00:03.0 chip-ID: 8086:160c class-ID: 0403 Sound Server-1: ALSA v: k5.17.8-arch1-1 running: yes Sound Server-2: PulseAudio v: 15.0 running: no Sound Server-3: PipeWire v: 0.3.51 running: yes

Welcome to :enos: forums @lucilfer!!
Please post system logs according to this post:

1 Like

hey hey
here’s the system logs https://clbin.com/WbVS5

what about boot logs as stated in the article?
Boot log:

journalctl -b -0 | eos-sendlog

Edit:
This might help with your issue:
https://wiki.archlinux.org/title/Advanced_Linux_Sound_Architecture#Unmuting_the_channels

oh my bad, i thought only the hardware info were required
here is the boot logs https://clbin.com/5hnJU

also i tried what you linked and the issue is still the same.

Have you tried using the LTS kernel? It may help

It looks like your BIOS is out of date
May 19 20:14:03 luc-bridges kernel: DMI: Dell Inc. Latitude 7350/02R62J, BIOS A05 04/23/2015
This is the latest version from Dell
https://www.dell.com/support/home/en-au/drivers/driversdetails?driverid=pmpdw&oscode=wb64a&productcode=latitude-13-7350-laptop
https://wiki.archlinux.org/title/Dell_Latitude_7370

hii i updated the BIOS and also i’m using the LTS kernel and its still not working

It’s beyond me then, someone with more knowledge should hopefully be able to help you

1 Like

if headset is working – it could be 2 things internal speaker is muted… or it is disabled .

alsamixer in terminal can help on see if a channel is muted … the easy way…
And check pavucontrol config tab…


for disabled devices…

logs show also some issues… i am not sure… but currently there are a lot users complaining about audio issues… in most cases resetting configs do work…

May 19 21:32:14 luc-bridges pipewire[777]: spa.alsa: hw:broadwellrt286: snd_pcm_avail after recover: Broken pipe
and more…

moving used configs out of the way for pipewire-media-session:

mv ~/.config/pulse ~/.config/original-pulse
mv ~/.local/share/state/pipewire ~/.local/share/state/orginal-pipewire

or if wireplumber is used the state files are different:

mv ~/.config/pulse ~/.config/original-pulse
mv ~/.local/state/wireplumber  ~/.local/state/original-wireplumber

and reboot…

4 Likes

tysm. the second method worked

1 Like

was this offline install?

no it was an online one

1 Like

would be nice of you to send the installer log … so i can have a look?

cat /var/log/endeavour-install.log | eos-sendlog

1 Like

np, here it is https://clbin.com/tJMLy

that`s great thanks for the log !

I see it installs pipewire-media-session and it is what will be used on your system…

[PYTHON JOB]: ".. selected DE i3"

Hmm if you would have installe done of the Full DEs i would have think it could cause issue with pipewire… but i3 ? strange… as it should not do any stuff related to that on its own…
But i will check.

May we have something in the configs that needs a change for latest pipewire changes.