No audio after pacman -Syu yesterday evening

Yes:
alsa-monitor.conf.pacnew
and
media-session.conf.pacnew

Strange… that seems to be what others have done? :thinking:

Maybe you’ll have to uninstall the audio packages and reinstall them. I just installed pipewire-pulse and pipewire-alsa which has removed pulse audio. I’m not having any issues with sound.

2 Likes

Any orphaned PA configuration files can be removed to avoid any conflicts etc. (whether under /etc, $HOME/.config etc.).

To verify, you did something like:

sudo rm /etc/pipewire/media-session.d/alsa-monitor.conf
sudo mv /etc/pipewire/media-session.d/alsa-monitor.conf.pacnew  /etc/pipewire/media-session.d/alsa-monitor.conf

?

1 Like
sudo mv /etc/pipewire/media-session.d/media-session.conf /etc/pipewire/media-session.d/media-session.conf.2021-04-07    
sudo mv /etc/pipewire/media-session.d/media-session.conf.pacnew /etc/pipewire/media-session.d/media-session.conf

sudo mv /etc/pipewire/media-session.d/alsa-monitor.conf /etc/pipewire/media-session.d/alsa-monitor.conf.2021-04-07
sudo mv /etc/pipewire/media-session.d/alsa-monitor.conf.pacnew /etc/pipewire/media-session.d/alsa-monitor.conf

This file was already there, so certainly shouldn’t remove it, should I?

WHich packages exactly would this include? There are a lot of pipwire and alsa packages and pipwire-alsa packages.

Did you replace the two files as @jonathon suggested with those exact commands?
Edit: If you aren’t understanding what was written just ask him then.

He did, he just made a backup first instead of just removing it :wink:

I installed pipewire-pulse and pipewire-alsa.

Ok, so I’ll do:
sudo pacman -R pipewire-pulse
sudo pacman -R pipewire-alsa
sudo reboot
sudo pacman -S pipewire-pulse
sudo pacman -S pipewire-alsa
sudo reboot

Is this, what you did?

Could remove pipewire-alsa, but not pipewire-pulse:

$ sudo pacman -R pipewire-pulse
checking dependencies…
error: failed to prepare transaction (could not satisfy dependencies)
:: removing pipewire-pulse breaks dependency ‘pulseaudio-bluetooth’ required by gnome-bluetooth
:: removing pipewire-pulse breaks dependency ‘pulseaudio’ required by paprefs
:: removing pipewire-pulse breaks dependency ‘pulseaudio’ required by pulseaudio-alsa

Could use option -Rdd instead of -R. Then it will not check dependencies.

And would you reboot after remove and before reinstall? Dangerous?

Tried it on a test machine (different hardware, alas: Old lenovo X220 instead of a new HP Elitebook):

sudo pacman -Rdd gst-plugin-pipewire pipewire pipewire-media-session

Result: Sound system still working, output and input. So, I’m in doubt, that reinstalling pipewire will change anything for the better.

Did you reboot? Try that first before making any decisions… :wink:

But if it still works, then no reason to fix it. :sweat_smile:

Yes, I did. could mean, pulsaudio does all the sound? ANyway, see my next post.

I have gotten a bit farther: Following https://wiki.archlinux.org/index.php/PipeWire#Microphone_is_not_detected_by_PipeWire (see “No devices detected after PipeWire update and reboot (git / >=0.3.23)” I exec’ed:

systemctl --user enable --now pipewire-media-session.service

I now have sound and microphone!

Well, almost: Sound of videos running in Firefox work, VLC as well, but MS Teams has its difficulties. I hear the jingle when dialing, which then stops abruptly and a message appears that there are no speakers. Hanging up I hear the jingle again. In MS Teams’ settings it reads “Speaker: None”. Any ideas how I can make MS Teams see my audio system again?

Ah, this could be important: The test option (Control Center → Sound → Hardware → Test Speakers → Front Left Test / Front Right Test) in Gnome doesn’t work either.

Another one: If I run MS Teams thru apulse, it works, speaker and micro. In its settings it reads: “Speaker: default and only sink”.

Great that you’ve made good progress! :sweat_smile:

It may be some DE specific thing causing issues.

I guess our audio expert @ricklinux can help you more. Or anyone else that knows about audio issues more than I do.

This SCREAMS a kernel issue.

Are you on the linux latest kernel? (I would bet you are)

Have you tried the linux-lts kernel with the same issue? Zen?

Audio/bluetooth issues after an update are very common on the latest kernel as they continue to build it. Use akm and please try at least the lts kernel. Verify on two is even better. If you run into hardware type issues, especially after an update, trying another kernel should always be step 1.