Night Light


EndeavourOS Linux

this fix seems not in the kernel yet. Any ideas in which, it will be availble? Thanks!


I’m not quite sure if xrandr even applies to wayland. So if you want to change gamma and brightness on wayland, you need to use something else.

1 Like

What DE are you using? KDE, for example, has this functionality, and I believe GNOME has as well.

1 Like

X11 or Wayland, GNOME or KDE all have Night Light not working because it is not in the kernel, see question and link. Thanks.

I no try this yet ! i no have sway/wayland install atm ( so use @ own risk )

i find this some time ago + find it interesting . you might find interesting

" "

1 Like

It seems you know the answer better than us. I don’t even know what is it that you’re asking…

You’re welcome, I guess… :man_shrugging:

1 Like

I use redshift for this, it is in the repos. You can either schedule night light, have it on at all times or turn it on when you feel like it. I haven’t tested it on ARM, but it works great on my desktop and laptop. It uses randr by default, but you can change the mode to other options too.

1 Like

The question is as stated above, if anyone happens to know when it finds its way into the ARM kernel. Let me close the question and patiently wait for the fix. :slightly_smiling_face: Appreciate all responses.

If you really need help then contact He is the man behind manjaro arm. Maybe he can help/


He says they do not maintain the ARM Arch kernel. Who does?

Arch Linux Arm kernel is maintained by the Arch Linux Arm folks at:

Once there, click on “Forum” and see if there are any Threads on the subject.

here is a list of all the platforms they support.


1 Like

I registered to their forum but looks like the Admins need to grant access. Hopefully, this will not take too long. Then, I will post the link to the thread.

EDIT: the board members need to be contacted when a user is not able to log in but their contact address is only seen when logged in. Does anyone have an account and post a contact here?

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.