Night Light feature stopped working after upgrading to Gnome 45

Night light feature in Gnome stopped working after I upgraded to Gnome 45.
The night light toggle switch has no effect on the color temperature.

System details:

# System Details Report

## Report details
- **Date generated:**                              2023-10-10 10:44:43

## Hardware Information:
- **Hardware Model:**                              ASUSTeK COMPUTER INC. ASUS TUF Gaming A15 FA507NU_FA577NU
- **Memory:**                                      16.0 GiB
- **Processor:**                                   AMD Ryzen™ 7 7735HS with Radeon™ Graphics × 16
- **Graphics:**                                    AMD Radeon™ Graphics
- **Disk Capacity:**                               (null)

## Software Information:
- **Firmware Version:**                            FA507NU.312
- **OS Name:**                                     EndeavourOS
- **OS Build:**                                    rolling
- **OS Type:**                                     64-bit
- **GNOME Version:**                               Not Available
- **Windowing System:**                            X11
- **Kernel Version:**                              Linux 6.5.5-arch1-1

Screenshot from 2023-10-10 10-44-16

welcome onto the purpelization :enos:

Is shown here running under propritary Nvidia crumbles…
Funny thing… it does not work under wayland but starting xorg session it works…

IME Night light has always been ‘random’ under Wayland (Intel graphics) and I was hoping 45 improved things.

I’ve not updated the laptop yet (Intel Wayland) but desktop (AMD Xorg) is fine so far

The proprietary Nvidia driver does not support GAMMA_LUT under Wayland, which is necessary for Night Light, iirc.

Aside from that I’m getting the impression that Wayland’s not quite ready for its prime, yet.

EDIT: Oh, where are my manners? Welcome to the community, elrond.


thanks for the info…
So looks mainly like Nvidia is not implementing this is the issue?

They haven’t shown any intent to do so at the moment. The Plasma developers have therefore chosen a shader-based workaround for KDE’s Night Colours once Plasma 6 is released (which doesn’t support X11 any longer).

not really true :wink: as KDE development will only change default to wayland you can still use Xorg session with plasma 6 … at least from my point of information… Some Distros will build kde without Xorg support but i do not think arch will do so…


Nvidia recently added support for GAMMA_LUT in their 545.23.06 beta drivers.

Added support for the CTM, DEGAMMA_LUT, and GAMMA_LUT DRM-KMS CRTC properties. These are used by features such as the “Night Light” feature in GNOME and the “Night Color” feature in KDE, when they are used as Wayland compositors.


hmm should i try it out ?

545.23.06 beta works for me. ‘‘Night Color’’ works as expected while in plasma wayland session.

Though VRR (Variable refresh rate) is completely broken in this driver release. Maybe they’ll fix it before their production branch release.

Alright, I apparently misunderstood the announcement, then.

Wayland by default

Link to task

We’re going to make a very strong push for Wayland to be the default session type for Plasma 6. The X11 session will still be there of course, and distros will be free to override this and continue defaulting to X11 if they feel like it suits them better. But we want Wayland to be our official recommendation.

To get there, we went over our “Wayland showstoppers” wiki page with a fine-toothed comb to refine what we really consider a showstopper. We decided that a lot of them are really more like annoyances rather than showstoppers, because X11 has plenty of annoyances of a similar severity too! The true showstoppers are down to five, plus a couple of NVIDIA issues that need further investigation. Many of these issues are in progress with a clear path towards resolution, so I do expect us to be able to achieve the goal!

1 Like

Odd. When this thread began I checked and Night Light indeed was not working. A week later it is back. Don’t know if it was an update, or if an extension was screwing it up.

1 Like

Mine is not Nvidia and night mode doesn’t work yet.
It was so urgent to get free from X11?

Does it at least show a colour preview when you move the colour temperature slider around? That would be an indicator for that your location could not be acquired automatically rather than the Night Color / Night Light not working.

1 Like

You know, you’re right. Would you suggest me how to give location info to the system?

I’ll try my very best from memory as I’m using KDE at the moment:

  • Open Control Center
  • Navigate to Privacy
  • Enable Location Services

Afterwards, Night Light should work as expected.

1 Like

Have you try to modify the Clock? It’s weird that the app doesn’t let us just to toggle it on/of. At least that was the case for me.

Default gnome, no extension.

Yes, now it works, thank you.

it does not work for me i have a rtx 4060 with endevour drivers installed and in the beginning it worked but after some updates it stoped working, sory for my broken english.
Can anyone help please?
Also i am new to endevour or any arch distro.