Newly installed zen kernel not listed in grub

So I used “akm” to install the lts kernel, and I successfully booted to the lts kernel.
Then I used “akm” again to install zen kernel and zen headers, and to remove linux and linux-headers.
Then I ran sudo grub-mkconfig -o /boot/grub/grub.cfg
I still don’t see the zen kernel in grub, and if I try to boot to the standard linux kernel which still appears in grub, it fails.

/etc/default/grub:

# GRUB boot loader configuration

GRUB_DISABLE_SUBMENU=y
GRUB_DEFAULT=saved
GRUB_SAVEDEFAULT=true
GRUB_TIMEOUT='5'
GRUB_DISTRIBUTOR='EndeavourOS'
GRUB_CMDLINE_LINUX_DEFAULT='nowatchdog nvme_load=YES loglevel=3'
GRUB_CMDLINE_LINUX=""

# Preload both GPT and MBR modules so that they are not missed
GRUB_PRELOAD_MODULES="part_gpt part_msdos"

# Uncomment to enable booting from LUKS encrypted devices
#GRUB_ENABLE_CRYPTODISK=y

# Set to 'countdown' or 'hidden' to change timeout behavior,
# press ESC key to display menu.
GRUB_TIMEOUT_STYLE=menu

# Uncomment to use basic console
GRUB_TERMINAL_INPUT=console

# Uncomment to disable graphical terminal
#GRUB_TERMINAL_OUTPUT=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `videoinfo'
GRUB_GFXMODE=auto

# Uncomment to allow the kernel use the same resolution used by grub
GRUB_GFXPAYLOAD_LINUX=keep

# Uncomment if you want GRUB to pass to the Linux kernel the old parameter
# format "root=/dev/xxx" instead of "root=/dev/disk/by-uuid/xxx"
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
GRUB_DISABLE_RECOVERY='true'

# Uncomment and set to the desired menu colors.  Used by normal and wallpaper
# modes only.  Entries specified as foreground/background.
#GRUB_COLOR_NORMAL="light-blue/black"
#GRUB_COLOR_HIGHLIGHT="light-cyan/blue"

# Uncomment one of them for the gfx desired, a image background or a gfxtheme
GRUB_BACKGROUND='/usr/share/endeavouros/splash.png'
#GRUB_THEME="/path/to/gfxtheme"

# Uncomment to get a beep at GRUB start
#GRUB_INIT_TUNE="480 440 1"

# Uncomment to make GRUB remember the last selection. This requires
# setting 'GRUB_DEFAULT=saved' above.
#GRUB_SAVEDEFAULT=true

# Uncomment to disable submenus in boot menu
GRUB_DISABLE_SUBMENU='false'

# Probing for other operating systems is disabled for security reasons. Read
# documentation on GRUB_DISABLE_OS_PROBER, if still want to enable this
# functionality install os-prober and uncomment to detect and include other
# operating systems.
#GRUB_DISABLE_OS_PROBER=false
GRUB_EARLY_INITRD_LINUX_STOCK=''

What shows ls -al /boot ?

ls -al /boot
total 196897
drwxr-xr-x  5 root root     4096 Jun 20 17:28 .
drwxr-xr-x 17 root root     4096 Jun 17 09:10 ..
drwxr-x---  4 root root     1024 Jan  1  1970 efi
drwxr-xr-x  6 root root     4096 Jun 20 17:24 grub
-rw-------  1 root root 62159464 Jun 20 12:51 initramfs-linux-lts-fallback.img
-rw-------  1 root root 19337371 Jun 20 12:49 initramfs-linux-lts.img
-rw-------  1 root root 65128479 Jun 20 17:27 initramfs-linux-zen-fallback.img
-rw-------  1 root root 19674929 Jun 20 17:27 initramfs-linux-zen.img
-rw-r--r--  1 root root  8116224 Jun  1 03:46 intel-ucode.img
drwxr-xr-x  2 root root     4096 Jun 19 10:21 syslinux
-rw-r--r--  1 root root 12943872 Jun 20 12:48 vmlinuz-linux-lts
-rw-r--r--  1 root root 14225920 Jun 20 17:27 vmlinuz-linux-zen
1 Like

Could you run this again and post the output?

sudo grub-mkconfig -o /boot/grub/grub.cfg
[sudo] password for shmuel: 
Generating grub configuration file ...
Found background: /usr/share/endeavouros/splash.png
Found linux image: /boot/vmlinuz-linux-zen
Found initrd image: /boot/initramfs-linux-zen.img
Found fallback initrd image(s) in /boot:  initramfs-linux-zen-fallback.img
Found linux image: /boot/vmlinuz-linux-lts
Found initrd image: /boot/initramfs-linux-lts.img
Found fallback initrd image(s) in /boot:  initramfs-linux-lts-fallback.img
Warning: os-prober will not be executed to detect other bootable partitions.
Systems on them will not be added to the GRUB boot configuration.
Check GRUB_DISABLE_OS_PROBER documentation entry.
Adding boot menu entry for UEFI Firmware Settings ...
done

They seem to found by grub-mkconfig.

Check your /boot/grub/grub.cfg and see if you have menuentries for linux-zen in there.

Also, have you by any chance used Grub Customizer before?

So running sudo grub-mkconfig -o /boot/grub/grub.cfg again fixed it. I am now on zen kernel

inxi
CPU: 8-core Intel Core i7-9700 (-MCP-) speed/min/max: 800/800/4700 MHz
Kernel: 6.9.5-zen1-1-zen x86_64 Up: 0m Mem: 1.43/15.49 GiB (9.3%)
Storage: 2.26 TiB (40.3% used) Procs: 238 Shell: Bash inxi: 3.3.34

I did not use Grub Customizer on this installation.

1 Like

Great!

Nice!

Good!

1 Like

I see that it’s already solved but I do have a question. Why are you wanting to use the zen kernel?

Basically to try it out. The benchmarks published by phoronix don’t really show much benefit from zen over the standard linux kernel, but I don’t have a discrete GPU, or installed software that requires dkms, so I figured I don’t have much to lose by trying.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.