Newly Installed Font Shows as Squares

So I installed a new font and put the folder in /usr/share/fonts/ . The Font shows up as squares in the XFCE Appearance Settings, but shows up fine in fontforge. I tried running sudo fc-cache -fv



you should read the wiki page about the fonts.

/usr/share/fonts/ is under the purview of the package manager, and should not be modified manually.

For system-wide (all users) installation, place your fonts under /usr/local/share/fonts/.

  • You may need to create the directory first: mkdir -p /usr/local/share/fonts.

something you should also consider

The font files need to have sufficient read permissions for all users, i.e. at least chmod 444 for files, and 555 for directories.

Thank you very much! Making the directory, copying my directory there and setting the right permissions solved the issue.

Now the issue is they are all italic, but in fontforge they are not except the italic one.


1 Like

show the output of the following command

fc-list | grep borda
/usr/local/share/fonts/Borda/Borda ExtraBold Italic.ttf: Borda,Borda 11:style=Regular 2,Regular
/usr/local/share/fonts/Borda/Borda Italic.ttf: Borda,Borda 2:style=Regular 11,Regular
/usr/local/share/fonts/Borda/Borda DemiBold.ttf: Borda,Borda 10:style=Regular 3,Regular
/usr/local/share/fonts/Borda/Borda ExtraBold.ttf: Borda,Borda 9:style=Regular 4,Regular
/usr/local/share/fonts/Borda/Borda Medium.ttf: Borda:style=Regular 12,Regular
/usr/local/share/fonts/Borda/Borda Bold.ttf: Borda,Borda 8:style=Regular 5,Regular
/usr/local/share/fonts/Borda/Borda Light Italic.ttf: Borda,Borda 3:style=Regular 10,Regular
/usr/local/share/fonts/Borda/Borda Bold Italic.ttf: Borda,Borda 7:style=Regular 6,Regular
/usr/local/share/fonts/Borda/Borda.ttf: Borda,Borda 4:style=Regular 9,Regular
/usr/local/share/fonts/Borda/Borda Light.ttf: Borda:style=Regular,Bold
/usr/local/share/fonts/Borda/Borda DemiBold Italic.ttf: Borda,Borda 6:style=Regular 7,Regular
/usr/local/share/fonts/Borda/Borda Medium Italic.ttf: Borda,Borda 5:style=Regular 8,Regular

looks good. I’m guessing a software problem with fontforge. unfortunately I don’t know about it.

They show up fine in libreoffice. They’re only italic in XFCE which makes them appear italic in other applications like Microsoft Teams.


it seems GTK and some electron applications don’t handle the font properly. I’ve tried a few things, unfortunately without success. I’ll keep looking for a solution, I’ll get back to you.

Thank you very much! I will keep the thread open for now.

I made the font known in xorg in various ways, went through the arch wiki, LFS. Despite the system showing me that it worked, it is not displayed correctly :cry:. Guess that’s because of how the applications were programmed and that’s why the font is incompatible in some applications :man_shrugging:

Thank you for your hard work. That’s a shame, I am trying to make a very specific desktop theme with this font. I tried to add it in the terminal, but it was not listed. :thinking: