Newbie - Problems with Canon printer


I’ve tried to install the Canon printer MB2750.
Cups is installed and running, the firewall does not block ipp and ipp-client.
Cups-filter are installed.

The printer is recognized in the printer panel (KDE)


But if I want to print, the printer is always busy and the printer status is known.

I tried several drivers without any success. The scanner can be accessed by the system (Skanlite or Skanpage).

Does anyone have an idea or hint where to look?


Did you try this one?

yay -S canon-pixma-ts-5055-complete

Did you stop firewalld to make absolutely sure that the firewall is not the problem?

sudo systemctl stop firewalld


I have diabled the firewall

Yes, with no success.

Not sure which printer protocol you are selecting?

@ricklinux What do you mean? Do you have more in detailed information for me to understand my “issue”? I found a solution (see next post), but I’m not sure why :wink:

I’ve installed now the packet “cnijfilter2”, used the driver mentioned on the Canon Website.
It didn’t really work.

Than I tried:

lpadmin -p printername -E -v ipp:// -m everywhere

And it worked, the printer is now “installed” and I can use it.
Well, I’m not sure why I have to go this way :thinking:

I did it on another (Manjaro) installation a few months ago, only with installing the cnijfilter driver and selecting from the printer menue.


Glad you have it working. I never seem to have these issues at least with the printers i have. I just install the printer and select it from the menu and it works but I’m using cups and it is a local printer on usb so I’m not using ipp.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.