New user account login freezes

I installed EOS (Artemis) with Plasma, and setup the system as I always do, and everything works fine, but when I made a new user account, after typing the password and hitting [Enter], the login screen freezes. I removed the user and tried again, no change, I reinstalled fresh, changed nothing at all, created the 2n’d user account, and got the very same problem. :sob:

The mouse still moves, but clicking on things, typing, function buttons… nothing works and I have to manually restart the computer. The first user I created can be logged into with no problem. :face_with_symbols_over_mouth:

I am using the user manager (Always do) in the system settings and think somethings busted! I know I can try via the command line as soon as I look up how exactly, but I don’t like the command line! :grimacing: I would love to know whats broken, as I searched the web and found nothing younger than 3 years, nor was any of it the same problem.

What is the hardware? Post the link. You could do this from the live ISO if necessary.

inxi -Faz | eos-sendlog

Will do, but It’s the very same computer I used up until last month when I built myself a new system, and I reinstalled the OS a few times, and never had that problem.

Okay but I have no idea what it is. A plasma install should not do this.

Edit: Is this the old computer or the new one you built?


Link isn’t working? :thinking:

I hand typed it because Im working n two computers, here’s a pasted version:

Okay I see you have an older Nvidia GTX 9800 graphics card. Currently is running on Nouveau. When you installed it did you use the Nvidia option? This card needs the 340.xx verion drivers. I think if you install them your issue might just go away.

Edited: Actually you can install the 340XX drivers from the AUR.

yay -S nvidia-340xx-dkms

Let me try that and see if it works, but it’s odd it wouldn’t inherit the same driver and function of the already existing account.

Did you install nividia drivers?

Edit: I don’t think it will install the 340xx version from the installer. It only works for newer cards.

Edit2: You need to install them with yay after installing EndeavourOS.

I did it from the system: My user account works, just not the newly created one.

After I installed it, I couldn’t shut down, as none of the buttons (Shutdown, Logoff and Restart) worked. I used the terminal. Now it booted up and froze at:

[ OK ] Reached Target Multi-User System
[ OK ] Reached Target Graphical Interface

(two last lines).

Are you able to hard restart it somehow?

Edit: If it booted up can you switch to a TTY?

Not sure how to do that. I tried the Fallback initramfs, same problem.

If you end up reinstalling at some point i think i would install it using the default menu entry from the live ISO. It should install it with nouveau open source drivers. Then i would reboot and go into a TTY and install the nvidia 340xx driver from the AUR and then reboot. I don’t know what else would help.

I used the default, not the Nvivia option knowing it’s an older card, and had a working system. That’s how I always did it on that computer.

I don’t see how creating a new user has anything to do with the graphics card or driver though. Why would it expect anything other than what’s already working; as in use the nouveau driver, just like the other account?

I Don’t know how (and when) to get a TTY on boot.

Could have something to do with the groups the new user is a member of. The first user was created as a member of several system groups. You can tell with the groups command. Then compare the group membership of the second user. The usermod command allows you to add your user to groups with the syntax:

usermod -a -G {list groups to add separated by spaces} {username}

usermod -a -G power sys adm username

where power, sys, and adm are the system groups you want your username to be added to. Make sure to use the -a switch to append groups to the user and not replace the already existing groups memberships. You would need to logout and log back in for the changes to take effect. Look at the --help for the usermod command for more info.

1 Like

I know all of that, but when adding a user via Plasmas user manager it does all that. Those are not necessarily the groups that one wants either, especially not if you don’t want them to have administrator rights, and also not recommended for new users. Besides that, if not administrator they automatically get added to the usr group, and none of that should effect loging in/make the login freeze.

BTW: there is the wheel group, which one can give all in it sudo rights via the sudoers file.

And I did (always do) check the group file, and it had the user in all the right groups. Something is not right elsewhere.

I am going to create the user via the terminal and see what happens. If it works then the user manager is borked and I can file a bug report at KDE, if it doesn’t then I will have to dig deeper into the problem over at Arch.

Well, seems that when I tried to add the user via the terminal, it threw up a message (Not in these exact words):

“User folder already exists, not writing skeleton (or key) files.”

As I have done for years, I added a few partitions to mount as /home/USERNAME during OS install, then after install I would have my user folder as /home/USERNAME which is a partition mounted to home. Later, when I add users I add a partition to mount in /home with their user name, and when they login for the first time, the drive gets populated with everything that needs to be there. It also works by adding the drive and mount point in fstab, and then creating the user.

Well now it doesn’t work anymore! :face_with_symbols_over_mouth:

I also remembered that I had the same problem years ago, maybe on Antergos, or even before then when distro hopping: I had to comment out the new users drive in fstab and delete the user, reboot, and login as the new user, and it would create a user folder in /home. Then I rsynced its content to the user drive (mounted in /mnt/USERNAME), force delete the user folder, and finally un-comment the drive in fstab, reboot, and viola’, the user can login. :laughing:

Strangely that’s exactly how I always have it for the initial user, and had no problem with it for a long time. Most of the time the home/USERNAME drives are already populated from before I reinstalled the OS, and it finds the files, and doesn’t overwrite any, and I can create the user, login, and It’s like I never reinstalled the OS. This time (every 2 years) I want everything fresh because leftovers from programs and obsolete stuff from changes to software… gets too much, making it harder to navigate, wasting space.

The EOS installer let me partition and mount them that way, and put its needed user files on the partition; no problem.

Looks like I have work to do. :sunglasses: