New update broke my dunst / notification settings

So after around a week I updated my system and after that my setting that I applied to my notification no longer works. It appears that xfce notification changed some setting that is conflict with dunst daemon. Any idea how to fix it. This settings has been working fine for me for months.

$ systemctl --user status dunst.service 
dunst.service - Dunst notification daemon
     Loaded: error (Reason: Unit dunst.service failed to load properly, please adjust/correct and reload service manager: File exists)
     Active: inactive (dead)
       Docs: man:dunst(1)

Sep 25 20:10:00 lenovo-i315 systemd[1083]: dunst.service: Two services allocated for the same bus name org.freedesktop.Notifications, refusing operati>

I have the same problem, change xfce4-notifyd’s executable flag:

sudo chmod -x <path-to>/xfce4-notifyd 

At work but think it was /usr/bin, then reboot.

1 Like

Do you mean xfce4-notifyd-config ? There is no other binary with that kind of name in the path (using bash completion). This one opens the notification settings , which I don’t think effect the daemon.

sudo chmod -x /usr/lib/xfce4/notifyd/xfce4-notifyd

Back at home :smiley:

I doesn’t work , now if I try any notify-send command it fails:

Error calling StartServiceByName for org.freedesktop.Notifications: Timeout was reached

Did you reboot?

Yes, I was forced to add +x permission and boot back again.

Oh well, perhaps somebody else has an idea.

Thanks, weird that it worked for you but not me. Do you use dunst or only something similar?

deadd-notification-center and hyprland on an xfce base install.

I see, so it maybe behave differently for you. I just have dunst on the base EOS install from ISO which is defaults to XFCE.

It is a shame it broke, I was working on customizing my notify-send messages and adding custom icons to each. All of that work is useless now :frowning:

I found this:

❯ find /usr/share/dbus-1/services -iname '*Notifications*.service' 

I found the solution somewhere else, in case others have this problem:

In /usr/share/dbus-1/services/org.xfce.xfce4-notityd.Notifications.service we should change the line Name=org.freedesktop.Notifications to Name=org.freedesktop.NotificationsNone. And reboot.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.