New to EndevourOS - week 1

A quick introduction, I’ve been a distro hopper for some years now, since Ubuntu Hardy Heron, and have tried most of them with varying levels of success. Arch was always something that seemed out of my league though.

Most recently I’ve been drawn back to MX , but after seeing an article about Arch on ‘It’s FOSS’ I thought I’d give it another go. Yes, it loaded and worked but what the article left out was that it was a real bare bones install. Not even a browser. And yes I know that’s the beauty of Arch, but the article could have said that.

Anyway, I then thought I’d give Endeavour another go - holy cack! this is good.

Fast, very good to look at, no extra ‘guff’ installed, I can add as much or as little as I like.

And to do that I can just type ‘yay and the package name’ and off we go.

I couldn’t log on to KDE Connect - after a quick look I see Bluetooth isn’t enabled by default - no problem, a couple of commands and bingo.

Firewall is on by default so another command and KDE Connect is up and running.

Just need to work out how to set the firewall up for Noson - not that I need it as I usually run the Sonos app from my phone. But because I can :wink:

Arch is chuffing awesome!



Arch is a Build it yourself Distro so you add your choices to the OS and not someone else’s including a Web Browser. As far as what should have been stated in the Article well you’ll have to take that up with the authors :smiley:

1 Like


I’m new on the block too, and very impressed as well. EOS-team is working wonders, I believe :smile:

1 Like

Hello! glad to meet you; from another user! :wave:
May you have the best of good times with your EOS install and for many years :smile:

:carpentry_saw: :hammer: :wrench: :screwdriver: :pick: building everything yourself, to your needs, will make it awesome :wink:

See you down the log! :penguin:

If you ever figure that one out I’d be grateful for sharing. :pray:
I never could get noson to work through firewalld and eventually gave up. Now I just run a script that turns off the firewall, runs noson and restarts the firewall. I’m a bit ashamed of this solution, but it is what it is. :disappointed:

1 Like

Welcome to the forum @ianm549

1 Like

Welcome to :enos: - Forum @ianm549 :rocketa_purple: :enos_flag:

1 Like

you have to find the port (read the noson documentation) that noson needs then make a rule for this in FirewallD. or you might have to make a profile for it in firewalld? not a fan btw :grinning:
Much easier said than done since firewalld much more sprawling than my intellect. in ufw I used to make a port allow rule in the terminal and boom. don’t think it’s that easy with this beast.
From a Sonos Dev:
"Hoser Rob, thank you for your swift reply.
Yes, I’m using gufw.
On the gitter forum I found this comment by Janbar ( Noson’s developer):
“First you have to check your router doesn’t block the SSDP trafic on lan: multicast SSDP is used by to discover upnp devices. Then the fw should allow ingoing packet from udp Second your fw should allow ingoing tcp packet to the host on ports range 1400-1409. One of those ports is bound by the app to listen upnp events from the connected Sonos devices. You can have up to 10 instances of the app. Obviously the outgoing trafic have to be allowed.”

the info itself is firewall-agnostic…it seems a PITA…so what you are saying is the flatpak Noson or AUR Noson you got is not ready out of the box? I mean these don’t configure themselves to work right away?

1 Like

Join Us GIFs | Tenor

1 Like

Many thanks for the warm welcome :wink:

I was having trouble logging in and kept getting the ‘Cannot log in from this IP address’ or ‘You can’t request a password reset from this IP address’ turned firewall off - no luck.

It turns out that I have to be running through my VPN. I use Proton and yet again a couple of commands in yay and it was installed. It was a right pain in other distro’s.

Anyway, I’m in and will go in search of a solution for Noson.

Take care!

1 Like

It works ‘out of the box’ without a firewall - I had this on Mint/MX/Ubuntu etc. I can turn the firewall off to use it. But with my new found love for EOS I want to dive in and setup an exception :wink: