New Monitor Refresh Rate stuck at 50Hz

I bought this monitor today , for the life of me i can’t get the 165Hz refresh rate.

its set at 3440x1440 50.00Hz :thinking:

Tried arandr and the only thing is with the refresh rate, so not sure what to do now.

I’m running Gnome
GPU: Intel CometLake-S GT2 [UHD Graphics 630]
Kernel: 6.7.3-arch1-1

Should be 3440 x 1440 Resolution with 165 Hz Refresh Rate :man_shrugging:t3:

Have you tried xrandr?

Edit: See what it shows is available for the monitor from command.


I tried arandr and i get all the resolutions but my refresh rate for all resolutions says only 50.00Hz :man_shrugging:t3:

I get this with arandr also

[christopher@EndeavourOS ~]$ arandr

(arandr:4431): Gdk-CRITICAL **: 10:34:18.640: gdk_atom_intern: assertion 'atom_name != NULL' failed

(arandr:4431): Gdk-CRITICAL **: 10:34:18.640: gdk_atom_intern: assertion 'atom_name != NULL' failed
Gdk-Message: 10:35:24.747: Window 0x619955e42040 is a temporary window without parent, application will not be able to position it on screen.

(arandr:4431): Gdk-CRITICAL **: 10:35:24.749: gdk_wayland_window_handle_configure_popup: assertion 'impl->transient_for' failed

xrandr puts out

[christopher@EndeavourOS ~]$ xrandr
Screen 0: minimum 16 x 16, current 3440 x 1440, maximum 32767 x 32767
HDMI-2 connected primary 3440x1440+0+0 (normal left inverted right x axis y axis) 790mm x 330mm
   3440x1440     49.96*+
   1920x1440     49.98  
   1600x1200     49.92  
   1440x1080     49.98  
   1400x1050     49.97  
   1280x1024     49.84  
   1280x960      49.85  
   1152x864      49.91  
   1024x768      49.98  
   800x600       49.92  
   640x480       49.67  
   320x240       47.50  
   1920x1200     49.93  
   1680x1050     49.97  
   1440x900      49.88  
   1280x800      49.95  
   1152x720      49.76  
   960x600       49.65  
   928x580       49.91  
   800x500       49.62  
   768x480       49.78  
   720x480       49.96  
   640x400       49.70  
   320x200       47.17  
   2560x1440     49.96  
   2048x1152     49.98  
   1920x1080     49.93  
   1600x900      49.94  
   1368x768      49.84  
   1280x720      49.83  
   1024x576      49.81  
   864x486       49.61  
   720x400       49.63  
   640x350       49.52  
[christopher@EndeavourOS ~]$ 

Looks like it’s only showing 50 Hz. I wonder if you can set other. You graphics are Intel? Maybe try reading this section of the Arch wiki.

1 Like

Ok i figured it out, I went & installed Windows 11(I know I know lol.) :rofl:

Same thing 3440x1440 @50Hz, so i did more digging and it turns out I need HDMI 2.0 or better to get a high refresh rate(My motherboard isn’t that old lol.).

I thought, wait i have a practically brand new hardly used Sapphire Radeon RX570 4Gig. I shutdown installed it and Windows 11 recognized it i updated installed new drivers rebooted and boom 165Hz :rofl:

So later this week I’ll be re-installing EOS Gnome, sound works on Windows 11 but i don’t have my 5.1 like i do with Arch :rofl: :man_facepalming:

So I’ll mark this as Solved

Thanks @ricklinux :+1:

1 Like

What HDMI cable spec was the current cable 1.4? Cable spec and quality makes a huge difference. Certified cables are the best because they are guaranteed to meet the spec they are designed for.

I believe its 1.4 4K HDMI cable, but the Display Port Cable that came with the monitor is 1.4 or higher which is what I’m using at the moment.

Does it work on Display Port 1.4 spec then?

1 Like

Yup :+1:

1 Like

So no need to buy a new HDMI cable then. :wink:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.