New Laptop internal mic not working

I wiped Windows before testing anything so I can’t confirm if it’s defective hardware, but I’m assuming it’s not configured properly for Linux

My laptop lists an internal microphone so apparently I have one, it just doesn’t work. There’s no sound when I record anything with my voice. I got a tiny bit of sound when I recorded music on full volume playing through the speakers, but it was barely audible.

I tried playing around with jack retasker and it didn’t fix anything. I also tried switching all the audio settings in gnome and KDE and had no luck

Also, when I plug my headphones in the sound is really quiet and distorted, plus the external mic doesn’t work

Did you already check settings using pavucontrol or pulsemixer?

1 Like

Did you check alsamixer and see if it’s muted?

alsamixer

Check the ArchWiki on pipewire - I had to edit /etc/pipewire/media-session.d/alsa-monitor.conf:

https://wiki.archlinux.org/title/PipeWire#Microphone_is_not_detected_by_PipeWire

Yes, the volume is fine on everything

It’s not muted but is it normal to only have to entries when showing “all”?

share inxi -Fazy

I don’t have any of the folders listed there on my system

can u install sof-firmware reboot and see if this is fixed>

https://wiki.archlinux.org/title/Advanced_Linux_Sound_Architecture/Troubleshooting#Microphone

It’s already installed and up to date

This is correct and if you click anywhere on the image allows you to check other F key settings.

Edit: Check the Arch wiki as @archbtw said.

https://wiki.archlinux.org/title/Advanced_Linux_Sound_Architecture/Troubleshooting#Microphone

Edit: Also check mic in pipewire

https://wiki.archlinux.org/title/PipeWire

Try installing pipewire-pulse.

Thanks for all who offered help. I just installed windows and tested it out

Nothing works there either so it’s just a pile of garbage laptop

This is happening with me also. Laptop’s internal mic is not working but if I plug in external mic or earphones then I’m able to call or record clear sound.

On Pipewire.

EDIT : I just tried this https://wiki.archlinux.org/title/Advanced_Linux_Sound_Architecture/Troubleshooting#No_microphone_input and Internal Microphone recorded sound but the output was very low and crackling.

Can you post the link to this command for your hardware.

inxi -Faz | eos-sendlog

I’ve turned off my laptop now. I’ll send it tomorrow.

BTW I’ve a Windows VM, internal microphone was working flawlessly there. I also have a Fedora VM and Tumbleweed VM, both of them have the same issue of very low and crackling internal microphone sound. The problem is distro independent…lol

But it’s not a major problem for me as I always use my earphones while doing calls.

Working on Windows is meaningless when it comes to the reason it doesn’t work on a linux distro. It’s probably a hardware issue that takes some troubleshooting to try to figure it out. It could also be related to some of the software now being used in place of pulse audio.

https://clbin.com/Idc5S