new laptop - goes to sleep when powered off

hi yall, im hoping i can get some help here.

i just got a new laptop (lenovo yoga 7i) and installed endeavour os on it. almost everything works ootb except for 2 things:

  1. fingerprint sensor (it’s by goodix, it was as simple as flashing the firmware), and
  2. when i power off/ reboot the laptop, it goes into sleep mode

it’s really odd. i’ll power it off and it seems to go into a sleep mode (as in, the power light pulses). i have no clue why this happens. it even occurs when i call reboot from the command line. does anyone have any idea?

1 Like

Power Management Setting?

Have you tried with LTS kernel? I mean linux-lts. Because there’s a bug in the latest kernel with the behavior you describe (I have that problem with dell Optiplex; the problem is not there with the LTS kernel instead).

1 Like

hey y’all, i figured it out. it was because i flashed the firmware with an experimental driver. installing windows fixed it :slight_smile:

Me too the LTS is the only kernel that actually powers off/resets my machine