New kernel entries not being written to grub.cfg


So, I have a :enos: KDE instance installed as a virtual machine using VMware. It’s working no issues there. But I tried to install linux-lts kernel. I used akm. Once installation is done I rebooted and noticed LTS kernel is not listed in the GRUB menu.

Then I removed the LTS kernel and tried yay -S linux-lts linux-lts-headers which also didn’t seem to add any entry to the grub.cfg. I don’t see any error message getting listed when dracut is running. You can find the grub.cfg here

I’ve another :enos: vm using AwesomeWM which has LTS and it was installed using akm. Don’t know why it’s not being added to grub.

By default, grub-mkconfig isn’t run when new kernels are installed.

Try running sudo grub-mkconfig -o /boot/grub/grub.cfg


That fixed it. Why isn’t akm doesn’t do this if grub is installed?

There used to be pacman hook that did that. It worked fine most of the time, but when it didn’t, it was a disaster, and caused many computers running EndeavourOS to be unbootable.

1 Like

So the best to run both commands together like below.

yay -S <linux-kernel> <linux-kernel-header> && grub-mksconfig -o /boot/grub/grub.cfg

You can run them together or separately, it is just a matter of personal preference.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.