New installation on an hp envy-no success doing anything in terminal

During installation, it was not an installation that made use of the internet. I used a usb I had used to install on another laptop atleast about a year ago. I have not had any success trying to install updates or install any new programs.

The updates or programs will often have me remove one or more conflicting files, but then I get a long list of corrupted files I have to delete. So I can’t do updates or add anything new.

I at least don’t think my download of endeavors could have been too old. Wouldn’t updates sort all that out anyway? Is this laptop actually just incompatible? It seemed to install ok, apart from the listed issues. What could be going on here?

This is very long with a rolling release, I would suggest you try the latest ISO and report back

2 Likes

I cant help but think that maybe user error is part of the problem with updates. This installation is my first time trying to do updates.

AUR update check:
y:: Searching AUR for updates…
→ Missing AUR Packages: at-spi2-atk atk dbus-python endeavouros-skel-default endeavouros-skel-xfce4 grub-tools grub2-theme-endeavouros ipw2100-fw ipw2200-fw js78 yad-eos
→ Orphaned AUR Packages: libsidplay
there is nothing to do

OK, Im trying something new here. I just updated list of mirrors first. Now I am going to try.

What does it show if you run

sudo pacman -Syu

Edit: You can deal with the AUR packages after trying to update with pacman first.
Edit2: Please post the full output with code tags.

It’s already in the process of updating. I’m hoping the mirror update will mean I won’t just have to delete all the terminals hard work this time. I had simply followed the direction terminal had lead me. This seems of not in the beginning of this update. A few warnings.

:: Synchronizing package databases…
core is up to date
extra 7.9 MiB 33.2 KiB/s 04:03 [--------------------------------] 100%
community is up to date
multilib is up to date
endeavouros is up to date
resolving dependencies…
:: There are 2 providers available for dbus-units:
:: Repository core

  1. dbus-broker-units 2) dbus-daemon-units

Enter a number (default=1): 1
looking for conflicting packages…
:: at-spi2-core and at-spi2-atk are in conflict. Remove at-spi2-atk? [y/N] y
:: at-spi2-core and atk are in conflict. Remove atk? [y/N] y
warning: dependency cycle detected:
warning: harfbuzz will be installed before its freetype2 dependency
warning: dependency cycle detected:
warning: libcamera-ipa will be installed before its libcamera dependency
warning: dependency cycle detected:
warning: mesa will be installed before its libglvnd dependency

warning: insufficient columns available for table display

3 updates are currently at 100%, while the rest are working on it.

Just wait!

Edit: Let it finish and see if there is anything that stops it from updating and completing.

ok

You should always download and use the latest ISO when installing just for future reference if you get through this.

Is it still going? Hopefully your internet isn’t too slow and drops out.

It’s still going, but there are alot of 100%'s. So it is chugging along.

I’m not the only person using the internet.

Better kick those others off. :rofl:

Don’t own it. Extended family

1 Like

Oh, it’s 74/104

so far

104/104 done
"
(819/819) checking keys in keyring [--------------------------------] 100%
(819/819) checking package integrity [--------------------------------] 100%
error: linux-api-headers: signature from “Frederik Schwan frederik.schwan@linux.com” is unknown trust
:: File /var/cache/pacman/pkg/linux-api-headers-6.8-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
"

Try yes

Edit: This is where it becomes a pain if it doesn’t update as you’ll have to try all over again.

Do you want to delete it? [Y/n] y
error: glibc: signature from “Frederik Schwan frederik.schwan@linux.com” is unknown trust
:: File /var/cache/pacman/pkg/glibc-2.39+r52+gf8e4623421-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]

Do I just type yes for each, like I have done before?