New Installation, black screen on boot

Hello everyone,

I tried to install EndeavourOS on a framework laptop (i7-1165G7).
The installation completed with no error but when I reboot, the laptop display only a black screen and I can’t have a tty.

The black screen appear after I enter my disk encryption password.

The ISO I used is the lastest available : EndeavourOS_Artemis_nova_22_9.iso
I used Rufus to create the bootable USB.

I followed this tutorial for the installation.

I chose Online installation and KDE as desktop environment.

I already tried to uncheck the xf86-video-intel driver in the calamares installer without success.
Sans titre

I managed one time to boot successfully (without knowing why) but after a reboot the black screen came back.


Welcome to the forum!

Is ‘‘Enforce Secure Boot’’ enabled ?

If so then disable it. Go into your BIOS to Security → Secure Boot and disable “Enforce Secure Boot”.

Hello, yes secure boot is disabled

Welcome here! :smile:

Please show some details about your hardware using command

inxi -Faz | eos-sendlog

and show the returned URL here.

You should be able to boot using the USB installer drive and use the terminal for the command.

Hi, here’s the logs :

Some thoughts:

  • Motherboard firmware might have updates. If you update, make sure it is exactly for your motherboard, otherwise you may brick the board.
  • You have only Intel graphics. Often package xf86-video-intel is not needed for newer machines, but that’s not always the case. So either install it and reboot, or uninstall it and reboot. See if either helps.
  • Changing the display manager might help. For example, if you have lightdm, try sddm.

Changing the display manager:

sudo pacman -Syu --needed sddm    # the new display manager here
sudo systemctl disable lightdm    # the current display manager here
sudo systemctl enable sddm        # the new display manager here

I updated the bios, tried to install with and without intel driver and change the display manager but the black screen is still here.

I will try to install endeavour with the offline installation

I suspect that it will not help…

If the problem continues, we need more logs, like

  • cat /var/log/Xorg.0.log | eos-sendlog
  • sudo journalctl -b -0 | eos-sendlog

from the installed system, after trying to log in.
If you can’t log in, you can use either the USB installer, or the TTY (press e.g. Ctrl-Alt-F3 to get to a TTY) and run the commands.

With the USB installer, to get logs, you will need this info: (assuming you have an UEFI system).

Ok, so I installed endeavour with the offline installation, it’s work I can boot but after updating the system and reboot the black screen is back

Run grub-install after updates before reboot?

I did the grub-install after reboot with a live USB, I don’t know if it makes a difference

The new iso should not be a problem. However, we saw a lot of problems with grub update couple of weeks ago. It is necessary to run the command before rebooting, else necessitates a chroot and fix it there.

This explains the fix. Still surprised in your case, I did not have any problems with updates and reboot with new iso…

Also see some blacklisting of Nvidia, did you do that? Or was that automatic install.

module_blacklist=nvidia,nvidia_modeset,nvidia_uvm,nvidia_drm,pcspkr nouveau.modeset=1 i915.modeset=1 radeon.modeset=1 nvme_load=yes

Also your boot parameter is entirely different than mine. Perhaps try install first without encryption, or if you do run the grub-install before reboot but right after update if you can. Curious if it is really grub related.

I reinstalled endeavour with the offline installation, update, grub-install and reboot but the black screen is still there.

I will try to install endeavour without disk encryption.

I did not change anything about nvidia or boot parameter.

I tried without disk encryption and the black screen is still there
I don’t know what to do :frowning:

How about the logs mentioned above? :wink:

I can’t upload them, I don’t have internet connection when i use chroot and i can’t edit /etc/resolv.conf, maybe i’m missing something

I assume you do have internet connection with the USB installer, right?

Then arch-chroot into the system, redirect the outputs to a file, then exit arch-chroot, mount the proper partitions, and then run

cat "/path/to/the/file/you/just/created" | eos-sendlog

cat /var/log/Xorg.0.log:
sudo journalctl -b -0 :

1 Like
[     6.579] (EE) AIGLX error: dlopen of /usr/lib/dri/ failed (/usr/lib/dri/ cannot open shared object file: No such file or directory)
[     6.579] (EE) AIGLX error: unable to load driver i965

The second log is empty…