New Install Issues: Pacman 404s and Grub Can't Find Windows

Hi everyone,

TIA, and thanks for all the hard work so far, I really like what I’m seeing in EndeavourOS.

I just installed it and I’m having a couple of problems:

A. Whenever I install something, I get loads and loads of 404s. Here’s a screenshot. It always eventually finds what its looking for, but it takes ages. Anything I can do about this?

B. My Windows 10 installation isn’t being found. It’s not in the boot menu, and here’s what I’ve tried so far:

  1. I tried installing EndeavourOS in UEFI and BIOS modes, and neither found it. I’m not sure what Windows is using and I’m not sure how to determine which it is.

  2. I followed these instructions, including installing the ntfs-3g package, mounting the windows partition and running os-prober.

More details, not sure what’s important:

  1. When I run os-prober, it says “error: invalid volume” if that helps.

  2. The drive Endeavour is on used to have Fedora (for about 6 months), and previously, Antergos, for about 5 years. I was able to dual boot with both of those setups.

Thanks.

One final thing: I also had a problem with the video drivers. After installation I was greeted by a scrambled screen. I had to chroot into the EndeavourOS installation and install the nvidia package, and that sorted it out.

EDIT: The 404 problem seems to have been fixed by following the EOS wiki page on ranking the mirrorlist, and then running pacman -Syy

Welcome @c2lknt to EndeavourOS, :rocket:

If you want your EOS on UEFI, You have to deactivate the secure boot in your Bios.
To make it easier, could you show us a GParted screenshot to see your partition scheme on HDD ?

For the 404 error you are right about Mirror list

And for Nvidia driver you could see