New EndeavourOS Install Can't See Second SSD (Recent change?)

Hi guys. I’ve been using EndeavourOS for a while but I have ran into a weird issue.

Starting today, when I attempt to reinstall EndeavourOS on the same laptop I had it on before (and had installed it on as recently as last week), I can see (and I guess install to) either of my two SSDs in my laptop - one is an NVMe and the other is SATA - during the installer / live USB.
But once the system is installed, I can no longer see the SATA SSD (once I install EOS onto the NVMe) now.

I have tried installed the XFCE and KDE versions (prefer XFCE, just tried KDE as a sanity check). Installing Manjaro, that OS can see both hard drives after installation.
Gparted and lsblk both don’t see the secondary SATA SSD either.
I’ve tried formatting the SATA SSD in ext4, having it as no partition, having it have GPT or MSDOS style, but nothing changes it.

Since Manjaro can see both, it has to be EndeavourOS.
This has to be from something recently changed or updated, since it worked within the past two weeks just fine.
Any ideas?

Does seem a bit strange. I don’t see any reason why it shouldn’t see the SSD. Are you able to boot on the live ISO and post the url for

inxi -Faz | eos-sendlog

Edit: You do have secure boot and CSM disabled?

Edit: This is from the install. I will make one for the Live USB in one second.

Secure Boot is disabled. There is no setting for CSM on this laptop.

Check your settings and make sure SATA is set AHCI not Raid.

  Hardware-1: Intel Volume Management Device NVMe RAID Controller driver: vmd
    v: 0.6 port: N/A bus-ID: 0000:00:0e.0 chip-ID: 8086:9a0b rev: class-ID: 0104

Edit: This laptop may have RST so it should be set to AHCI or RST turned off.

Edit2: F.Y.I This is why the SSD isn’t showing on live ISO also.

I forgot to ask if you are dual booting with Windows.

Edit: If Windows is installed you would have to change to AHCI also in Windows and there is a trick to that.

There is no option for anything about SATA being RAID vs AHCI, or anything for RST. There’s Intel VTX and Intel VTD, which I’ve tried changing but had no results. This laptop’s BIOS is pretty bare bones actually…

I didn’t touch anything in the BIOS between the install within the last two weeks and today.

The Live USB does show the secondary SSD. There is no dual booting either, it’s just going to be a storage SSD.

Here’s the log from the Live ISO (the first one was from the installed system):

Okay that’s why i asked to boot on the live ISO to see if it was showing. Are you sure there isn’t a submenu that shows AHCI for either SATA mode instead of RAID or RST that can be turned off?

Yes. Like I said, this BIOS has almost no options whatsoever.

Are you able to turn RAID mode off?

Nope, nothing for that either.

I am in the process of doing a full Windows reinstall to try and update the BIOS in case they added that feature. But I am positive I changed nothing between installing this two weeks ago and now with the BIOS settings, and it used to work just fine. And since the Live USB sees it, something about the install makes it unable to see it. Why would a Live USB be able to see it but not the full install? Is there a package or anything that the Live USB uses that it doesn’t install, to see all drives?

That’s a good idea to update the Bios. I agree with doing that if there is an update.

Edit: Never mind i see what i need in the output.

I did get the BIOS updated but there are no additional settings avaliable there.

Any other thoughts? If other distros like Manjaro have no issue seeing the drive, why wouldn’t EOS, especially if it had no problem doing so less than two weeks ago?

It could be the latest kernel. You have to realize Manjaro runs it’s own repo and kernels are usually behind. EndeavourOS has all the latest Arch packages. The current kernel is 6.2-1 which just got updated.

Edit: The output on the live ISO is 6.1.9 and the installed system will have the latest kernel 6.2-1 so I’m assuming it’s a kernel issue.

You could try using downgrade to downgrade the kernel and kernel headers?

1 Like

I see… I’ve never tried messing with installing other kernels, is it even possible to downgrade the kernel in EOS? I know I see the ‘Zen’ kernel and the ‘LTS’ kernel in the installer.

Looks like I’m not alone:


sudo downgrade linux linux-headers 

Downgrade both to 6.1.9

Edit: I think the kernels and headers were at 6.1.12 before they changed to the 6.2-1 kernel

1 Like

Is there anything I need to do to prevent the kernel from updating?

I think it asks if you want to ignore them on upgrades.
Edit: What ever is in the cache you should be able to downgrade to.

Well, it looks like downgrading to 6.1.12 resolves the issue. That’s super strange.

That’s the kernel just before it got updated to 6.2-1 so that’s what i would do for now! Both the kernel and the kernel headers.

Edit: At least until it gets resolved which i assume it will?

Edit: Hope this helps.

Since 6.1 kernel seems to work, you could consider using the LTS kernel instead until upstream fixes this in some 6.2.x update.

Then you can also comment out the IgnorePkg line in /etc/pacman.conf for linux and linux-headers.

1 Like