Neverwinter Nights 2 destroys the whole GUI

I can’t access my operating system anymore, so I cannot give you details about logs, etc. But I can replicate my issue (tried 3 times, all resulted in full destruction). I installed the game to Ubuntu and Fedora and it works perfectly.

Steps to replicate:

  1. Install EndeavourOS with KDE Plasma and X11.
  2. Have an NVIDIA GPU (2060).
  3. Buy Neverwinter Nights 2 from GOG.
    4.a Install it via Lutris; or
    4.b Install it via a wine-wrapper from a random dude online (this step worked for me in Fedora).
  4. Open Neverwinter Nights 2.

What I was expecting:

Playing the game.

What happened instead:

A black screen happened with the music of the game going on.

What I have tried to solve the issue:

  1. Restarting, the laptop comes to a login screen, I login, then after a brief second of cursor the screen goes black.
  2. Tried systemctl restarting, enabling, disabling, reinstalling X server from CTRL+ALT+F3. Doesn’t solve my issue.
  3. Tried reformatting my conf files, deleting and installing again etc. Nothing changed.
  4. Tried reinstalling KDE, X11, and installing Wayland. The same.
  5. Tried deleting the game and wine, didn’t work either.
  6. Tried reinstalling NVIDIA, tried installing optimus-manager to go integrated/hybrid/nvidia versions. Nope.
  7. Tried various xrandr commands about Displays I found online like exporting defaults etc., all of them gave the same error: “Can’t open display”.
  8. After realizing the error is about display, I tried plugging another monitor to my laptop, didn’t work.

I will not be able to try your suggestions, unfortunately. Because I really am tired from all these trials in the last 3 days, and will explore Fedora for a few weeks (before I eventually turn back to EndeavourOS, which worked without any issue for a year). This is not a rant or anything, I just wanted to inform EndeavourOS team about a bug I found ^^.

Sorry to hear about your issues.
nothing we can do abvout this without any details, sadly.

You where installing using Nvidia boot option?
And as you mention try optimus-manager it will be an optimus notebook?
I do not know if you where runningh on nouveau drivers on Fedora and Ubunto (i think it will be the default) Nvidia Drivers needs some setup in cases.

At least proper Hardware info would help to see what we are talking about here.

Okay, I guess… :man_shrugging:

I doubt it’s a bug or a problem with EndeavourOS, but rather just your specific configuration not working nicely with this specific program. Maybe a runtime dependency missing, maybe wrong graphics drivers… We can only guess.

However, since you, the only person affected by it, are not interested in solving it, why should anyone else be?

If you’re happy using Fedora, use that, nothing wrong with that, the user nobody here minds…

So you installed a Windows 7 / Vista era game on EndeavourOS and installed it with a either Lutris or some random wrapper from random malicious…ermmm I mean dude online, and expected it simply to work…okay. Sorry not an EndeavourOS problem, not a bug, definitely a case of PEBCAK. You deliberately installed something you clearly did not examine, and had predictably bad results.

This is the best install option ever. :rofl:

Have you checked WineHQ for compatibility? It states gold of platinum which is really good.
Most games require vcruntime, d3dx9, d3dx11 and/or dxvk to run. You can easily install it with winetricks.
Some games require correct 32/64-bit wine environment.

It is always best to start with fresh wine environment (by default ~/.wine directory) for a new installation unless you plan to share it with multiple programs.

From personal experience NWN2 worked for me couple months back without an issue under i3wm EndeavourOS. If you change your mind and decide to try again… I can give you some pointers.

Hey Johannes,

Thank you so much for your answer. Here are the first batch of details:

HP Omen 15 Laptop with 16GB RAM, NVIDIA 2060 GPU and Ryzen 4080H CPU. I was using Nvidia 535 series proprierity drivers in both attempts. Indeed, it is an optimus notebook, where the first attempt was without optimus-manager software and the second attempt with it. I tried all integrated, hybrid and dedicated options in the second attempt.

@Kresimir: I am not happy using Fedora, I actually sincerely wanna turn back to EndeavourOS and I think I will, right after finishing this game. I will probably try it again in the near future by the way. I am also aware that not many may wanna check into this bug, though in case of someone does, thanks to them!

@nadb: Indeed that’s why I did. When I installed it through Lutris (4.a), I followed the instructions from WineHQ and there were no some random wrapper with -malicious- intervention (well, not so much at least). It was simply installing dxvk etc.

@vlkon: Thanks for your detailed answer. I am extremely happy to hear that it worked under your settings. I will try installing any other distro than KDE next time to see if the problem was due to a weird interaction between KDE/X11/NVIDIA, which is more than likely to say the least. Because in Fedora I have GNOME and it works. Maybe it’s not EndeavourOS and it’s just KDE/X11/NVIDIA interaction.

Extremely unlikely.

You will most likely get the same result on other DE as well. KDE is not some half-baked desktop environment. On the other hand i3wm is not a full desktop environmet but onyl a window manager. You may find that it lacks a lot of features you will need and you would have to invest a lot of time to learn how to work with it.

Out of these 3 KDE/X11/NVIDIA the most likely to break is NVIDIA with its proprietary drivers. But that would break the whole computer and not only one program.