Network Manager Limited Connectivity in KDE

Howdy folks! BTW, I love the new installer! I’m running into one problem. Not bad, eh? Only one? Well, here it is:

Whenever I log into the new EndeavourOS in KDE using ethernet or wifi, I get an error of Limited Connectivity. I have tried to make a configuration file based on the Arch Wiki using both methods listed (.set.enabled=false and just enabled=false) in a new file in etc/Network Manager/conf.d/20-connectivity.conf file. I might be able to go about 3 to 5 minutes before I get that error. Going to speedtest.net shows I’m plugging along great. I am using ExpressVPN, and I understand that VPN’s might block the ping to the connectivity servers. I’m trying to disable the ping request to keep this from popping up. How can I do this?

TIA

Please give us some info with inxi -Fxxxza --no-host and have you tried other kernels yet?

1 Like

At least give us the output of inxi -Na :smile_cat:

1 Like

Thanks. I have not attempted to change the kernels. Here’s from the first report:

Blockquote
System: Kernel: 5.13.13-arch1-1 x86_64 bits: 64 compiler: gcc v: 11.1.0
parameters: BOOT_IMAGE=/boot/vmlinuz-linux root=UUID=43601e14-dad6-4392-91ba-45db7f85b8df rw
quiet loglevel=3 nowatchdog
Desktop: KDE Plasma 5.22.4 tk: Qt 5.15.2 wm: kwin_x11 vt: 1 dm: SDDM Distro: EndeavourOS
base: Arch Linux
Machine: Type: Desktop System: Dell product: XPS 8940 v: N/A serial: Chassis: type: 3
serial:
Mobo: Dell model: 0KV3RP v: A00 serial: UEFI: Dell v: 2.1.1 date: 06/15/2021
CPU: Info: 8-Core model: Intel Core i7-10700 bits: 64 type: MT MCP arch: Comet Lake family: 6
model-id: A5 (165) stepping: 5 microcode: EC cache: L2: 16 MiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 92838
Speed: 1429 MHz min/max: 800/4800 MHz Core speeds (MHz): 1: 1429 2: 4467 3: 3509 4: 2671
5: 2043 6: 1432 7: 1012 8: 800 9: 1283 10: 800 11: 800 12: 800 13: 800 14: 800 15: 800 16: 1143
Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics: Device-1: Intel CometLake-S GT2 [UHD Graphics 630] vendor: Dell driver: i915 v: kernel
bus-ID: 00:02.0 chip-ID: 8086:9bc5 class-ID: 0300
Device-2: Logitech HD Pro Webcam C920 type: USB driver: snd-usb-audio,uvcvideo bus-ID: 1-13:8
chip-ID: 046d:082d class-ID: 0102 serial:
Display: x11 server: X.org 1.20.13 compositor: kwin_x11 driver: loaded: modesetting
unloaded: fbdev,vesa alternate: intel resolution: <missing: xdpyinfo>
Message: Unable to show advanced data. Required tool glxinfo missing.
Audio: Device-1: Intel Comet Lake PCH cAVS vendor: Dell driver: snd_hda_intel v: kernel
alternate: snd_soc_skl,snd_sof_pci_intel_cnl bus-ID: 00:1f.3 chip-ID: 8086:06c8 class-ID: 0403
Device-2: Logitech HD Pro Webcam C920 type: USB driver: snd-usb-audio,uvcvideo bus-ID: 1-13:8
chip-ID: 046d:082d class-ID: 0102 serial:
Device-3: C-Media C-Media USB Audio Device type: USB driver: hid-generic,snd-usb-audio,usbhid
bus-ID: 1-4:2 chip-ID: 0d8c:0008 class-ID: 0300
Sound Server-1: ALSA v: k5.13.13-arch1-1 running: yes
Sound Server-2: sndio v: N/A running: no
Sound Server-3: JACK v: 1.9.19 running: no
Sound Server-4: PulseAudio v: 15.0 running: yes
Sound Server-5: PipeWire v: 0.3.34 running: yes
Network: Device-1: Realtek vendor: Rivet Networks driver: r8169 v: kernel modules: r8168 port: 3000
bus-ID: 02:00.0 chip-ID: 10ec:2600 class-ID: 0200
IF: enp2s0 state: up speed: 100 Mbps duplex: full mac:
Device-2: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter vendor: Dell
driver: ath10k_pci v: kernel port: 3000 bus-ID: 03:00.0 chip-ID: 168c:0042 class-ID: 0280
IF: wlan0 state: down mac:
IF-ID-1: tun0 state: unknown speed: 10 Mbps duplex: full mac: N/A
Bluetooth: Device-1: Qualcomm Atheros type: USB driver: btusb v: 0.8 bus-ID: 1-14:7 chip-ID: 0cf3:e009
class-ID: e001
Report: rfkill ID: hci0 rfk-id: 1 state: down bt-service: disabled rfk-block: hardware: no
software: no address: see --recommends
Drives: Local Storage: total: 1.36 TiB used: 67.85 GiB (4.9%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Lexar model: 1TB SSD size: 931.51 GiB block-size:
physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 rotation: SSD serial:
rev: V1.0.5 scheme: GPT
ID-2: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 850 EVO 500GB size: 465.76 GiB
block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s rotation: SSD serial:
rev: 2B6Q scheme: MBR
Partition: ID-1: / raw-size: 232.88 GiB size: 228.16 GiB (97.98%) used: 67.83 GiB (29.7%) fs: ext4
dev: /dev/sda2 maj-min: 8:2
ID-2: /boot/efi raw-size: 100 MiB size: 96 MiB (96.00%) used: 29.5 MiB (30.8%) fs: vfat
dev: /dev/nvme0n1p1 maj-min: 259:1
Swap: Alert: No swap data was found.
Sensors: System Temperatures: cpu: 49.0 C mobo: N/A
Fan Speeds (RPM): cpu: 786 fan-2: 1005
Info: Processes: 311 Uptime: 3h 39m wakeups: 0 Memory: 31.09 GiB used: 2.01 GiB (6.5%) Init: systemd
v: 249 tool: systemctl Compilers: gcc: 11.1.0 clang: 12.0.1 Packages: pacman: 1244 lib: 269
flatpak: 0 Shell: Bash v: 5.1.8 running-in: konsole inxi: 3.3.05

And, here’s from the second:

Blockquote
Device-1: Realtek vendor: Rivet Networks driver: r8169 v: kernel modules: r8168 port: 3000
bus-ID: 02:00.0 chip-ID: 10ec:2600 class-ID: 0200
Device-2: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter vendor: Dell
driver: ath10k_pci v: kernel port: 3000 bus-ID: 03:00.0 chip-ID: 168c:0042 class-ID: 0280

Hope this helps.

Have you tried the r8169 module. This is a kernel module that should load on boot. It’s using the r8168 which is an installed package. As long as you have wireless you could try to remove the r8168 package and reboot and see if it loads the r8169 kernel module and works better. I just don’t want to tell you to remove it if you don’t have a means to reinstall it if the ethernet doesn’t work on the r8169 but it does say that that is the chip.

Hi @ricklinux I have to apologize that I’m an intermediate user, and don’t know the nuts & bolts of things like this. But, when I removed the r8168 and installed r8169, it renders Ethernet dead. Thank goodness I do have wifi, I was able to switch it back. And, this is what I get after I start up. Weird thing is, even with ExpressVPN, my rates are faster than I’m paying for. Go figure. Here’s what I see…

Well that’s why wanted to give the warning about it because i wasn’t sure if it would leave you dead in the water or not but i had a suspicion it could.

What is the issue exactly? Just the notification of limited connectivity or it’s a speed issue? Or something else?

Simply the notification, really. From what I understand, it’s the connectivity check Network Manager makes when it first connects to the internet. My understanding is that VPN’s can block this connection test to the server, and that’s why it shows as having limited connections. However, the network is working fine. There’s supposed to be a way to stop the Network Manager from making this initial check, but I can’t find a way to do it. I have tried using the instructions on the Arch Wiki, but they don’t work for me.

Did you try this?

/etc/NetworkManager/conf.d/20-connectivity.conf
[connectivity] 
.set.enabled=false

Yes, that’s the first version I tried. This is apparently disputed in the Arch Wiki, and I’ve also tried the alternative where you simply use enabled=false. Neither are working to stop the notification.

I started by using this link and discussion because I didn’t see it here first:

Did you create the file inside the path it gives?

Yes. My last screenshot shows the window on the upper right showing the path. The window below it is the opened .conf file showing the entry.

I saw on a Ubuntu thread where they added it in the NetworkManager conf file that creates the NetworkManager file but not sure whether that would work?

That’s pretty interesting! I do think I fixed it, though it might not be a pretty work around for it. According to the Arch Wiki,

The default host (configured in /usr/lib/NetworkManager/conf.d/20-connectivity.conf) is ping.archlinux.org

So, instead of using the file in the /etc/NetworkManager folder, I went to the /usr/lib/NetworkManager file, removed the line where it tries to ping the Arch servers, and put in the line of code from the other 20-connectivity.conf file in /etc/, [connectivity]
.set.enabled=false, restarted and I don’t see the error. I think it’s blocked from trying. My internet is still strong, and I’m not getting the Limited Connectivity error any more. It’s been 15 minutes, and all’s well so far. I’ll continue to test this today and tomorrow unless someone comes along and says I shouldn’t do that because of X, Y, or Z and gives me a different fix. Looks like we might have got it taken care of, @ricklinux !

Ya i found it interesting too not knowing and thinking maybe it’s pinging arch repos? :man_shrugging:

Yes that is exactly what i would try and i checked my kde and it has the same file. I’m not getting any notification issue but i don’t use vpn so that maybe the difference. I don’t know and I’m not even sure why they have this to begin with?

I think it’s just an internal check to make sure you’re connected when the Network Manager’s activated. I read somewhere (that Manjaro article maybe?) that it’s a potential security risk anyway. I honestly have no idea. LOL But, I do appreciate your time and efforts in helping me!