Network error 0: SSL handshake failed

when tryin’ to install themes i get “Network error 0: SSL handshake failed”
i’m on LTS

i’ll provide any information y’all ask for, almost any.

Installing themes on KDE can cause a lot of problems. There are many that are problematic. I run KDE and i don’t use very many global themes. I usually use a separate background and icons. There are some global themes that work. I’m not saying they’re all bad. Be selective and if they don’t install right away and work properly then don’t use it. Look for something else that works.

“Network error 0: SSL handshake failed”

This just means it’s trying to connect via ssl (secure socket layers) which is a security protocol and it’s failed for whatever reason. I couldn’t answer the reason why. :man_shrugging:

1 Like

Welcome @bloodyeyes how are you trying to install it? I find the easiest way to install themes is to get them from and either install them manually or use ocs-url (when using ocs-url you may be asked for your password if an sddm theme is included which sometimes takes a while to show up)

1 Like

good morning :slight_smile:

in the settings itself where i can select 'em, for themes, cursor, clock etc… they load, but installing them gives me a error and if i wait 3 seconds before installing i get this Handshake ssl error

When using the built’in functionality of System Settings for customization - your system is connecting to - which may be throttled if you are too quick to browse or search.

Your system time is likely offset +/- with more than an acceptable margin - especially it you are behind. The certificate is then validated at some future date which creates hickups in the connection.

Ensure your time is correct

sudo systemctl enable --now systemd-timesyncd

Also note - and be warned - the message you get in System Settings

Themes may be unmaintained or badly coded - there is no guarantee what-so-ever.

1 Like

gonna try it in a few minutes, time is behind? it’s the same as on my phone even the seconds? well however i’ll try.

coould be a placebo… but seems to have worked for now, ill watch out… most likely it really was the time sync :pensive:

I didn’t say your system was behind - it is a probable cause though for SSL errors.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.