Network (and other) problem

When it comes to this, I’m a newbie again! I cannot seem to solve this on my own - so here’s where I am.

After a reboot (following updates - as ‘suggested’) I had some anomalies occur. It started with the wallpapers not coming up correctly, or as fast as it should. The secondary monitor showed an incorrect version of the main one (rather than its own) - then bkanked - then slowly came up with the correct one. The rest of the usual setup was extremely slow to come up as well - although eventually it did show. Some things, such as PulseAudio, do not work. Sometimes the network seems OK, but not mostly - I can ping an address, but not a site.

Attempts at mitigation include downgrading more likely suspects (new kernel, etc) - no good effect. Tried changing the DNS source in /etc/resolv.conf - no further difference (still no site access).

As my choice of ‘fixes’ would be to ‘return to an earlier date’ of the install, I need the network to function enough to allow pacman to help.

The same thing happened to my similar Arch setup - and I didn’t run the updates on Garuda (which works fine - all on the same machine).

Any further idea on what is gone wrong - or how to troubleshoot it? I should be able to extract logs etc (not that I can see anything particularly helpful in them thus far - by passing them to the Garuda install for net access for posting. Which ones?

Thanks to anyone who can rescue this - if it can be done with less effort on my part than the hour or so it would take to re-install :grin: (no data is at risk - just all the customization I’ve done on EnOS, and it’s conkys, and its packages, and…

Of course - it wouldn’t hurt to learn something other than re-install when I suffer user failure…

1 Like

Some info would help, like which desktop, which network hardware.

inxi -N

Is good for network hardware, but I don’t think it is standard in EoS?


cat /var/log/pacman.log | grep "2020-09-NN" | grep -i upgrade

Change the day.

Bit of a runaround to get the data for you - but here it is:

Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: r8168

and last 3 days on record (lots of updates!)

Log from 13th

┌17:42:50 WD= [~]
└───freebird@nest ─:arrow_forward:$ cat /var/log/pacman.log | grep “2020-09-13” | grep -i upgrade
[2020-09-13T10:49:23-0400] [ALPM] upgraded linux (5.8.7.arch1-1 -> 5.8.8.arch1-1)
[2020-09-13T12:09:03-0400] [PACMAN] starting full system upgrade
[2020-09-13T12:10:07-0400] [ALPM] upgraded util-linux (2.36-3 -> 2.36-4)
[2020-09-13T12:10:07-0400] [ALPM] upgraded cups-filters (1.28.1-1 -> 1.28.2-1)
[2020-09-13T12:10:07-0400] [ALPM] upgraded libxkbcommon (1.0.0-1 -> 1.0.1-1)
[2020-09-13T12:10:08-0400] [ALPM] upgraded llvm-libs (10.0.1-2 -> 10.0.1-3)
[2020-09-13T12:10:08-0400] [ALPM] upgraded orc (0.4.31-2 -> 0.4.32-1)
[2020-09-13T12:10:08-0400] [ALPM] upgraded eos-update-notifier (1.8.7-1 -> 1.8.8-1)
[2020-09-13T12:10:08-0400] [ALPM] upgraded inkscape (1.0-6 -> 1.0.1-1)
[2020-09-13T12:10:08-0400] [ALPM] upgraded libssh (0.9.4-2 -> 0.9.5-1)
[2020-09-13T12:10:08-0400] [ALPM] upgraded libva (2.8.0-1 -> 2.9.0-1)
[2020-09-13T12:10:08-0400] [ALPM] upgraded libxkbcommon-x11 (1.0.0-1 -> 1.0.1-1)
[2020-09-13T12:10:08-0400] [ALPM] upgraded meson (0.55.2-1 -> 0.55.3-1)
[2020-09-13T12:10:08-0400] [ALPM] upgraded perl-alien-build (2.29-1 -> 2.32-1)
[2020-09-13T12:10:08-0400] [ALPM] upgraded python-pygments (2.6.1-3 -> 2.7.0-1)
[2020-09-13T12:10:08-0400] [ALPM] upgraded qt5-base (5.15.0-5 -> 5.15.1-1)
[2020-09-13T12:10:08-0400] [ALPM] upgraded qt5-declarative (5.15.0-2 -> 5.15.1-1)
[2020-09-13T12:10:08-0400] [ALPM] upgraded qt5-location (5.15.0-1 -> 5.15.1-1)
[2020-09-13T12:10:08-0400] [ALPM] upgraded qt5-multimedia (5.15.0-1 -> 5.15.1-1)
[2020-09-13T12:10:08-0400] [ALPM] upgraded qt5-speech (5.15.0-1 -> 5.15.1-1)
[2020-09-13T12:10:08-0400] [ALPM] upgraded qt5-svg (5.15.0-1 -> 5.15.1-1)
[2020-09-13T12:10:09-0400] [ALPM] upgraded qt5-tools (5.15.0-3 -> 5.15.1-1)
[2020-09-13T12:10:09-0400] [ALPM] upgraded qt5-translations (5.15.0-1 -> 5.15.1-1)
[2020-09-13T12:10:09-0400] [ALPM] upgraded qt5-webchannel (5.15.0-1 -> 5.15.1-1)
[2020-09-13T12:10:09-0400] [ALPM] upgraded rav1e (0.3.3-1 -> 0.3.4-1)
[2020-09-13T12:10:09-0400] [ALPM] upgraded qt5-webengine (5.15.0-5 -> 5.15.1-1)
[2020-09-13T12:10:09-0400] [ALPM] upgraded qt5-x11extras (5.15.0-1 -> 5.15.1-1)
[2020-09-13T12:10:09-0400] [ALPM] upgraded smartmontools (7.1-3 -> 7.1-4)
[2020-09-13T12:10:09-0400] [ALPM] upgraded welcome (3.4.21-1 -> 3.4.25-1)
[2020-09-13T12:50:00-0400] [ALPM] upgraded aura-bin (3.1.8-1 -> 3.1.9-1)
[2020-09-13T12:50:25-0400] [ALPM] upgraded brave-bin (1:1.13.82-2 -> 1:1.13.86-1)

Log from 14th

┌17:44:35 WD= [~]
└───freebird@nest ─:arrow_forward:$ cat /var/log/pacman.log | grep “2020-09-14” | grep -i upgrade
[2020-09-14T04:59:11-0400] [PACMAN] starting full system upgrade
[2020-09-14T04:59:24-0400] [ALPM] upgraded attica (5.73.0-1 -> 5.74.0-1)
[2020-09-14T04:59:24-0400] [ALPM] upgraded karchive (5.73.0-1 -> 5.74.0-1)
[2020-09-14T04:59:24-0400] [ALPM] upgraded kcoreaddons (5.73.0-1 -> 5.74.0-1)
[2020-09-14T04:59:24-0400] [ALPM] upgraded kauth (5.73.0-1 -> 5.74.0-1)
[2020-09-14T04:59:24-0400] [ALPM] upgraded kdbusaddons (5.73.0-1 -> 5.74.0-1)
[2020-09-14T04:59:24-0400] [ALPM] upgraded kconfig (5.73.0-1 -> 5.74.0-1)
[2020-09-14T04:59:24-0400] [ALPM] upgraded kwindowsystem (5.73.0-1 -> 5.74.0-1)
[2020-09-14T04:59:24-0400] [ALPM] upgraded kcrash (5.73.0-1 -> 5.74.0-1)
[2020-09-14T04:59:24-0400] [ALPM] upgraded kglobalaccel (5.73.0-1 -> 5.74.0-1)
[2020-09-14T04:59:24-0400] [ALPM] upgraded kcodecs (5.73.0-1 -> 5.74.0-1)
[2020-09-14T04:59:24-0400] [ALPM] upgraded kguiaddons (5.73.0-1 -> 5.74.0-1)
[2020-09-14T04:59:24-0400] [ALPM] upgraded ki18n (5.73.0-1 -> 5.74.0-1)
[2020-09-14T04:59:24-0400] [ALPM] upgraded kwidgetsaddons (5.73.0-1 -> 5.74.0-1)
[2020-09-14T04:59:24-0400] [ALPM] upgraded kconfigwidgets (5.73.0-1 -> 5.74.0-1)
[2020-09-14T04:59:24-0400] [ALPM] upgraded kitemviews (5.73.0-1 -> 5.74.0-1)
[2020-09-14T04:59:24-0400] [ALPM] upgraded kiconthemes (5.73.0-1 -> 5.74.0-1)
[2020-09-14T04:59:24-0400] [ALPM] upgraded kxmlgui (5.73.0-1 -> 5.74.0-1)
[2020-09-14T04:59:24-0400] [ALPM] upgraded kbookmarks (5.73.0-1 -> 5.74.0-1)
[2020-09-14T04:59:24-0400] [ALPM] upgraded kcompletion (5.73.0-1 -> 5.74.0-1)
[2020-09-14T04:59:24-0400] [ALPM] upgraded kservice (5.73.0-1 -> 5.74.0-1)
[2020-09-14T04:59:24-0400] [ALPM] upgraded kded (5.73.0-1 -> 5.74.0-1)
[2020-09-14T04:59:24-0400] [ALPM] upgraded solid (5.73.0-1 -> 5.74.0-1)
[2020-09-14T04:59:24-0400] [ALPM] upgraded kjobwidgets (5.73.0-1 -> 5.74.0-1)
[2020-09-14T04:59:24-0400] [ALPM] upgraded knotifications (5.73.0-1 -> 5.74.0-1)
[2020-09-14T04:59:24-0400] [ALPM] upgraded kwallet (5.73.0-1 -> 5.74.0-1)
[2020-09-14T04:59:24-0400] [ALPM] upgraded sonnet (5.73.0-1 -> 5.74.0-1)
[2020-09-14T04:59:24-0400] [ALPM] upgraded ktextwidgets (5.73.0-1 -> 5.74.0-1)
[2020-09-14T04:59:24-0400] [ALPM] upgraded kio (5.73.0-1 -> 5.74.1-1)
[2020-09-14T14:59:52-0400] [PACMAN] starting full system upgrade
[2020-09-14T15:00:18-0400] [ALPM] upgraded systemd-libs (246.4-1 -> 246.5-1)
[2020-09-14T15:00:18-0400] [ALPM] upgraded glib2 (2.64.5-1 -> 2.66.0-1)
[2020-09-14T15:00:18-0400] [ALPM] upgraded systemd (246.4-1 -> 246.5-1)
[2020-09-14T15:00:18-0400] [ALPM] upgraded glib-networking (2.64.3-2 -> 2.66.0-1)
[2020-09-14T15:00:18-0400] [ALPM] upgraded gstreamer (1.16.2-2 -> 1.18.0-1)
[2020-09-14T15:00:18-0400] [ALPM] upgraded gst-plugins-base-libs (1.16.2-2 -> 1.18.0-1)
[2020-09-14T15:00:18-0400] [ALPM] upgraded eos-bash-shared (1.2.5-1 -> 1.2.6-1)
[2020-09-14T15:00:19-0400] [ALPM] upgraded ghostscript (9.53.0-1 -> 9.53.1-1)
[2020-09-14T15:00:19-0400] [ALPM] upgraded glib2-docs (2.64.5-1 -> 2.66.0-1)
[2020-09-14T15:00:19-0400] [ALPM] upgraded gst-libav (1.16.2-2 -> 1.18.0-1)
[2020-09-14T15:00:19-0400] [ALPM] upgraded gst-plugins-bad-libs (1.16.2-13 -> 1.18.0-1)
[2020-09-14T15:00:19-0400] [ALPM] upgraded gst-plugins-good (1.16.2-3 -> 1.18.0-1)
[2020-09-14T15:00:19-0400] [ALPM] upgraded gst-plugins-bad (1.16.2-13 -> 1.18.0-1)
[2020-09-14T15:00:19-0400] [ALPM] upgraded gst-plugins-base (1.16.2-2 -> 1.18.0-1)
[2020-09-14T15:00:19-0400] [ALPM] upgraded gst-plugins-ugly (1.16.2-4 -> 1.18.0-1)
[2020-09-14T15:00:19-0400] [ALPM] upgraded libmagick6 ( ->
[2020-09-14T15:00:19-0400] [ALPM] upgraded systemd-sysvcompat (246.4-1 -> 246.5-1)
[2020-09-14T15:00:19-0400] [ALPM] upgraded welcome (3.4.25-1 -> 3.4.27-1)

Log from 15th

┌17:46:06 WD= [~]
└───freebird@nest ─:arrow_forward:$ cat /var/log/pacman.log | grep “2020-09-15” | grep -i upgrade
[2020-09-15T11:36:39-0400] [PACMAN] starting full system upgrade
[2020-09-15T11:36:42-0400] [ALPM] upgraded eos-bash-shared (1.2.6-1 -> 1.2.7-1)
[2020-09-15T11:36:42-0400] [ALPM] upgraded welcome (3.4.27-1 -> 3.4.31-1)
[2020-09-15T23:42:49-0400] [PACMAN] starting full system upgrade
[2020-09-15T23:43:23-0400] [ALPM] upgraded brotli (1.0.7-3 -> 1.0.9-1)
[2020-09-15T23:43:23-0400] [ALPM] upgraded htop (3.0.1-2 -> 3.0.2-1)
[2020-09-15T23:43:23-0400] [ALPM] upgraded libgudev (233-2 -> 234-1)
[2020-09-15T23:43:24-0400] [ALPM] upgraded linux (5.8.8.arch1-1 -> 5.8.9.arch2-1)
[2020-09-15T23:43:26-0400] [ALPM] upgraded linux-headers (5.8.8.arch1-1 -> 5.8.9.arch2-1)
[2020-09-15T23:43:26-0400] [ALPM] upgraded metis (5.1.0.p9-1 -> 5.1.0.p10-1)
[2020-09-15T23:43:26-0400] [ALPM] upgraded r8168 (8.048.03-26 -> 8.048.03-28)
[2020-09-15T23:43:26-0400] [ALPM] upgraded virtualbox-host-modules-arch (6.1.14-2 -> 6.1.14-4)

I strongly suspect itewas the 14th that triggered it - but between downgrades, package removals (kolourpaint - in case all the k* stuff was causing trouble) and running a new upgrade (in case the fix was already in) I’m not 100% sure :grin:

That’s why I want to get net access to reverse to the 12th - and then work forward slowly…

Try removing r8168 there is another thread on here about it.

On the 15th:

[2020-09-15T23:43:26-0400] [ALPM] upgraded r8168 (8.048.03-26 -> 8.048.03-28)
1 Like

More than ONE other thread - but I didn’t spot that hiding in the forest of updates! Off to try - at least 3 reboots to go…and hope, maybe!


Thank @Kresimir our favourite Croakation :rofl: :frog:


Will do - once I figure what else is wrong here :grin:
Anyway - it gave me back network access (now using r8169, as is Garuda) but the other oddities remain. I guess I’ll revert the state back to the 14th and track from there! Thanks.

Weird - now getting graphic anomalies while typing this - it is ‘breaking up’ then coming back OK…

Well - off to revert!

Have you tried removing r8168

sudo rmmod r8168

Boot and it will load the r8169 or at least it should because it’s in the kernel modules where as r8168 is an installed package. If everything works remove the r8168.

I removed the r8168 package as suggested, and it used r8169 successfully. It made no difference to the other (graphic and crawling issues) things I have going on. I have piles of cups complaints too - which is odd since I haven’t even installed the printer on this setup yet. When the game is over, I’ll back up a few days, and see what happens and when…

1 Like

Seems a lot of people are having these strange issues. I’m not having any since virtual box is now working for me. :wink: I just did another UEFI update on my Ryzen board. It had a new AGESA so I updated it. The only issue is I find it wipes out my entry for rEFInd in UEFI Soni have to reinstall it to get the entry back.

Well - I reverted to 14/09 - and it didn’t help. Then I reverted to 12/09 - and still no improvement. Whatever it is must not be update related - or maybe not main repos update related (though how an AUR program could cause this I have no idea. At least it seems to run OK once I get it up - apart from weird graphics breakups right in what I’m typing! I’ll switch to Firefox to see if that help THIS at least! :grin:

No idea what this could be…

Is the graphics issue on Brave or Chromium? I only use Firefox and i have Chromium as a backup and Chromium has to have hardware acceleration disabled in the settings of the browser or you get graphics issues.

I’m just going to do some testing on the latest ISO.

Yeah - I remember that - and it’s on Brave. Strange that it shows up after so much time, though! Maybe I should revert further back into time - I was really happy with how everything worked. I hope I haven’t developed a hardware problem! (it IS doing the same thing on an Arch install). I guess first I’ll go over the garuda and see how it does with the upgrades applied (so far it seems OK).

Just thought I’d post an update on the situation:

I have the problem solved - but I have no idea why! :slightly_smiling_face: I moved some ENV settings into ~/.profile (mostly to do with scaling on hi-dpi and cleaning up the look of QT apps) - and at first they seemed to work better there than in ~/.bashrc. However - their presence in that file was causing all the strange behaviour! I removed the file, and ALL the issues went away - the holdups, the weird wallpaper showing troubles, the graphics oddity in Brave…

So a solution - but not an explanation! So now only sound is giving problems (also concurrent with the rest) - but I’ll start another thread if I can’t trace/fix that tomorrow.

Edit: the sound is back on the Arch build too - so maybe it ALL is fixed!?