Netgear Wifi dongle (mt7612u) hangs OS on connect as of kernel 6.1.1

As stated above - After updating to kernel 6.1.1, my system completely hangs as soon as my Netgear AC1200 wifi dongle (mt7612u) connects to the internet. This does not happen when using my Android phone’s wifi via USB Tethering, and it doesn’t happen when using an older Realtek-based Linksys WUSB6300 wifi dongle (rtl8812au, requires external driver to get working).

1 Like

I discovered the same issue with my system, it even locks up when I select the fallback choice on the grub screen. I haven’t tried swapping out for my Edimax dongle yet. At the moment I am posting from my Win 10 boot.

Happens to me, too. Got a AWUS036ACM (802.11ac AC1200 High-Speed USB Adapter) from ALFA Networks. Worked without problems until kernel 6.1.1. Now whenever it connects to the internet the system freezes.

Should one report this somewhere or rather wait for 6.1.2?

It seems there already is a fix, so 6.1.2 will probably fix it. See here and here.

Sadly, the fix was left out of 6.1.2…

1 Like

For me this was only an issue with kde plasma. Try switching to a different DE and see if that works, it did for me.

6.1.3 should hit the repo soon. Maybe it’s in there.

No dice; I’m on Cinnamon.

It worked for me for the day but now its the same issue. I even tried Manjaro to see if it was a distro unique problem. It’s not, it’s a kernel issue. I know you can revert to an early kernel, maybe try that until it’s solved for the mean time?

I downgraded kernels just to make my life easier.

It seems that the proposed patch got accepted for the kernel. So we will most likely see this being fixed in 6.1.5 or maybe it will be fixed for arch as a patch for the current kernel.

I just tried out 6.1.5 and no joy. Hard freeze as soon as the network was coming up. Back to 6.0.12.

The next kernel (6.1.7), which is currently in testing, will fix this bug.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.