Neofetch isn’t installing as it simply would in other Distributions

Hello,

New to using EOS and found I couldn’t install Neofetch. Not a major issue but is that the case across the board in all flavours of EOS?

How did you try to install?

What went wrong?

Some info, like terminal output, could help us to help you.

No.

This is absolutely not enough information.

If it does not install for you you certainly have some error message or the like. You need to provide the command you used to install it and the output of that command.

My apologies I tried with Yay, so it was sudo yay install Neofetch from memory.

It was late last night, forgive me and I’m not in front of the system right this moment.

Will re-run and give proper output.

yay -S neofetch
4 Likes

Oh wow, thank you. It seems I have some learning to do since my Manjaro days 3 years ago! I know they are very different but I’ve been Debian for a long time since!

You don’t use sudo with yay.
It will prompt you for your admin passwd when needed.

2 Likes

Thank you.

I am going from memory but I recall pamac having the sudo command before. So no need for such a thing here!

Thank you very much, this is why I love Linux so much as there are so many options and little things to learn from :+1:t2:

Didn’t you learn to use the search function of the pacman package manager on Manjaro?

pacman -Ss neofetch
extra/fastfetch 2.8.6-1 [installed]
    Like Neofetch, but much faster because written in C
extra/hyfetch 1.4.11-1
    Neofetch with LGBTQ+ pride flags!
extra/neofetch 7.1.0-2 [installed]
    A CLI system information tool written in BASH that supports displaying

also:

1 Like

With yay as has been mentioned, no. It will prompt you when you need to give your passwd.

With pacman, it depends:

  • No sudo >> when you search for packages or make inquiries about packages
  • Yes sudo >> when you install packages and update your system, that is when you actually make changes to your system

EnOS doesn’t use pamac unless you want it and install it yourself from AUR.

3 Likes

I didn’t actually! I guess you could say I was a rather simplistic user :blush:

Yay uses fakeroot

Says yay everytime i download something off it also you could’ve used pacman why yay then?

Do not use a already made pkg manager rather build your own with 3k+ lines of go , rust and python altogether its almost 5k :smirk:

1 Like

That would be sudo apt-get install neofetch if you were using a debian based distro. This aint debian and it sure as heck isn’t ubuntu. :face_vomiting:

May i suggest the discovery page. :wink:

You can also use the man pages.

1 Like

I detest Ubuntu lol

I love Debian however but I think I’m falling for EOS a little :blush:

All installed perfectly fine so need to mark this as solved!

Edit:

Please check the solution box under the post by @flyingcakes linked to here below:

Neofetch isn’t installing as it simply would in other Distributions - #5 by flyingcakes

2 Likes

@The_Homer_Simpson

Sorry for not having been clear! Please see my edit in the post above!

Oh yes! Lol I see! :joy:

1 Like