Neofetch doesn't display logo image and falls back to ascii

Hello,

I have just started using Endeavour OS, and linux in general. One of my friends which has been using linux for the past 3 years now, and is now running Endeavour as well, helped me install the system and explained most of the thing to me. I have a decent i believe grasp of the basics, however i have some problem when using Neofetch.

I am trying to edit the config file in ~/.config/neofetch/config.conf, however i have some problem when trying to set the image. I already set

image_backend="chafa"

and

image_source="/home/(user)/zedlogo.jpg"

and for some reason neofetch keeps showing me the ascii art of the selected distro (Artix), i customized it because it seemed like a nice logo

This is how neofetch looks

This is the directory where i keep my file /home/(user)/zedlogo.jpg. It is the directory in which the terminal is opening on default.

I’ve searched for a day now, and still haven’t found the answer. Please help! :slight_smile:

I can also post my config file if that’s needed :slight_smile:

Maybe you could try the following command to see if it works that way. Are you sure jpg images are supported? Maybe try with a png file.

neofetch --image ~/path/to/img.png

So in your case it would be

neofetch --image ~/zedlogo.jpg

Edit: also probably it’s best to leave the backend on “auto”.

Edit2: Did you check the wiki? Maybe you need other optional requirements.

Edit3: Also maybe your terminal doesn’t support it. Inside the link they suggest to install w3m-img and use " w3m google.com" to check if it works.

yea so even after i run it with the image attribute in terminal it still doesn’t work, both for png
and jpg.

also the image_backend doesn’t have an auto attribute, it is default on ascii and in my
friends config file is set to chafa (it is like pixels for refference)

And, i’ve also tried with absolute path however it still doesn’t work.
Moreover, i’ve also tried chafa zedlogo.png and chafa zedlogo.jpg and it works independently
however it doesn’t in neofetch :confused:

@I0F

i did check the wiki but ill look again… :confused: anyway ty for the reply :smile:
@I0F

Ah, my bad about the backend. Somehow slipped up a bit and mixed up image source and backend values.

It’s weird that it doesn’t work. You could compare your whole config file with your friends config file. Maybe there is another option that does the difference.

Well we did that, i even went as far as to get his config file, and overwrite mine. After that i put my image
directory and still didn’t work :confused:

EDIT: im looking into w3m-img now the thing is i can install the w3m pacakge and i don’t know if ihere is
a difference between w3m pacakge and w3m-img pacakge

EDIT 2: w3m seems to work, but there is also another package called imagemagick

https://archlinux.org/packages/community/any/neofetch/

w3m (or other packages) seem to be necessary to display images in neofetch. See the optional dependencies inside the link.

Maybe try neofetch again with w3m installed.

Thank you! :smile: i went to the Arch Wiki and uninstalled every possible dependencies together with neofetch, and then reinstalled each one manually prior to reinstalling neofetch. Thank you @I0F

1 Like