Nemo, thumbnails problem

Hi all,

A fresh install here. I’m having this issue with thumbnails in Nemo:
image

This is supposed to be an old problem, based on what I’ve read on the internet, but I can’t found how to solve it.

That fix button in the screenshot seems to do nothing. I’ve also tried sudo nemo --fix-cache with no result.
If I delete the thumbnails folder inside cache folder, the message dissapear…just for a while. It always comes back.

Do you have any tips on how to permanent fix this?

Thanks in advance!!

If the prompt is saying that you need sudo rights to alter files in your $HOME directory then it’s possible your file permissions are incorrect.

To reset all permissions so all files and directories are owned by your user, run:

sudo chown -R $USER $HOME

If that doesn’t help, make sure the dependencies required for thumbnail generation are installed:

$ pacman -Si nemo
...
Optional Deps   : cinnamon-translations: i18n
                  ffmpegthumbnailer: support for video thumbnails
                  catdoc: search helpers support for legacy MS Office files
                  ghostscript: search helpers support for PostScript files
                  libgsf: search helpers support for MS Office files
                  libreoffice: search helpers support for legacy MS Office powerpoint files
                  odt2txt: search helpers support for LibreOffice files
                  poppler: search helpers support for PDF
...

I’m sorry to say, but nor of that worked. I think it’s not a problem about writting permissions because if I delete thumbnails folders, it will be created again and also its content. I think it could be about the files that I have, but I’m not sure and I don’t know how to debug this or where to look.

I’m just thinking out loud:
I’ve been looking again to de ownership of the files and I think it’s something weird, because in fact I can’t change that ownership.

If I open Nemo with sudo so I can change permissions in a gui, every time a try to change the user, it automatically comes back to root:

No matter which user I select here, root always remain. It happens the same if I try to change the ownership from console.

Do you think that is normal?

Are these files owned by root to begin with, or is something running as root altering those permissions after the files are created?

Where are these files located on your system? For example, are they on an NTFS partition?

1 Like

They are in /home…and yes, I’ve mounted /home on an NTFS partition (I know it is not the best…). Do you think it is related to be a NTFS partition?

What mount options do you have for the NTFS partition in /etc/fstab ?

This:

I haven’t change any of this from the default installation.

Well, I had some urgency, so finally I’ve done another fresh install, this time formatting everything to ext4. The problem is gone.

So I can’t say that this problem was solved, but…it isn’t a problem for me anymore.

Just a guess, but based on your fstab, all the files/directories on /home would be owned by root. Since this is a constraint of your mounting options, chmod wouldn’t actually change the permissions. In case anyone else runs into this issue, I believe adding the mount options uid and gid would fix the issue.

Relevant information from man mount:

Mount options for ntfs
...

uid=value, gid=value and umask=value
           Set the file permission on the filesystem. The umask value is given
           in octal. By default, the files are owned by root and not readable
           by somebody else.